iRacing Crashing - Possibly Fanatec software

Hi guys,

First time post here and i am pulling my hair out and need some advice. Recently i started having an issue where i would load into a server (online or offline, didnt make a difference) and i could sit in the pits for hours if i wanted to, but as soon as i drove out and got to pit exit, iRacing would completely crash without warning. Then about 10 seconds later, the iracing menu would re-appear. This happened randomly but is now happening all the time and its getting very frustrating!

I ran the windows dx diagnostic tool and have found the error as attached. Something to do with fanatecapp.exe i think is causing iracing to crash. So i just want to see if anyone has encountered something similar and how they went about fixing it. I am running all of the latest release firmware and fanalab software. I even went so far this morning as to completely remove everything from my pc and reinstall it, but the issue remains.

Please help!



  • I might post this in the driver release section as well just in case Maurice has seen this before...

  • Hello, did you find something? I get this more and more and it's really anoying. I had up to date drivers and tried the beta ones without success

  • Hello, i have same problems!

    Without the slightest sign, iRacing freezes and 10 seconds later, it's back to the UI where I have to wait to be able to join the session again.

  • Yes, i got the same bloody issue, spent hours already reinstalling drivers, bios updates etc...nothing worked so far

  • Yeah, I'm getting a screen lockup and the wheel is going full force to the end stop.

  • Has this been fixed? I am also getting screen lockup and the wheel using full force based on what direction I was turning at time of freeze.

Sign In or Register to comment.