Driver 447 doesn't update ANY firmware at all

Allow me to start with an unrelated note, but the previous Driver (439) never told me me there was a new Driver available, and I vividly remember checking it via the "Check for Update" button multiple times, because I thought this also checks for new firmware.

Now for my problem specifically - as per title, while Driver 447 does show that new firmware is available, but it doesn't actually update anything.

I'm using the Gran Turismo base, McLaren GT3 V2 rim and ClubSport V3 pedals.

When the update is supposed to begin, the LED on the base starts flashing blue as it should, but the update never happens and it returns an error that points me to the logs folder. The base never stops flashing; I have to unplug it from power to use it again.

Pedals do not want to update either, even if the base is not connected to my PC. When I try to update them, Firmware Manager insists that they are now updated, but they disappear from the list of connected devices. I replug them and they are still on 1.32 instead of 1.35 that supposedly was installed.

Three attempts, same result every time, even after multiple PC restarts. I also tried firmware recovery but to no avail. This Driver's firmware updater just doesn't work for me but luckily I had no bricking incidents at least. Am I missing something obvious here?

Comments

  • I also tried uninstalling and installing the Driver today but that did not help.

    What did help, however, was repairing the Driver's installation.

    This thread can now be closed.

Sign In or Register to comment.