CSW2.5 POWER-UP Problem

After 1 yr of service without any complaint, my wheel base is not powering up properly. If I press the power button I can hear a noise (for a fraction of a second) and nothing happens (not powering up). If I keep pressing the Power-up button the PC detects the Wheel Base and ask if I want to upgrade or restart. After selecting restart the wheelbase works as always has been, but I need to repeat this procedure every single time I want to turn it on.

I did try disconnecting all cable for 30 seconds and powering up again, but no luck, still the same. I sent an email (customer service ticket) to Fanatec 5 days ago, but still no response.

anyone has experienced something similar? any ideas how to resolve it?



  • It´s even worse with my DD1PS4. It does not detect, does not go into flashing mode, steering wheel´s gear indicator is off, DD1´s display stays off, only 100% cooling fan and reference search until I release the button. The button´s white light glows consistant while pressed. Every case has a different combination of malfunctions. I wrote the support recently, I will post any replies.

  • Fast service, 41,95€.

Sign In or Register to comment.