Firmware upgrade 450 stuck immediately

Whenever I try to upgrade my CSL DD wheel base motor and mclaren gt3 v2 wheel using firmware version 450 the firmware updater immediately get stuck on Please wait... I can hear the device disconnecting from the Windows sound and the LED on the base keeps changing from blue to yellow to red.

After powering down the base and restarting it, it still works, but with the old firmware version.

I'm using windows 11 (22H2) and the current firmware of the wheel base motor is and should be upgraded to and the firmware version of the wheel is 45 to be upgraded to 46. I've already tried reinstalling the driver, but the result remains the same.


  • Do you use a USB Hub or USB extension cable?

  • No, I've also already tried switching the USB port (both of them on the mother board back plate and not the front case ones), but the result was the same

  • After switching it to one of the front case USB ports, I was able to update the wheel base motor, but now the same problem occurs while trying to update the wheel firmware. I think I've tried about every single USB port while restarting my pc in between. The only difference now is that it gives both a windows device disconnected sound and a windows device connected sound right after each other. The Fanatec firmware manager application also just stops responding and can only be closed through the task manager or by restarting my pc.

  • I'm having the same problem, although i dont have a fanatec wheel rim, could it be the non fanatec rim is causing the problem?

  • Antonio ValleAntonio Valle Member
    edited April 23
    hello .... I have the same problem 
    since yesterday, I updated to
     version 450 and none of the 4
     fanatec rings can be updated,
     it is a constant loop .....

  • Only got my Fanatec bundle delivered the other day.

    I have the same problem and I’m unable to update the McLaren GT3 V2 wheel. It does the windows disconnection bong and then just sits doing nothing. Then get an error message. Wheel base and motor updated no problem.

  • Same problem for me too:

    I sent the base and steering wheel for assistance, even if everything worked correctly in the game.

    I'll update you as soon as they return.

  • I've managed to update the firmware by installing the drivers on a completely different pc and installing it from there. No clue why or how this worked, but it did

  • Since the assistance they have changed a piece. The steering wheel is back already updated.

    I too had tried on two different notebooks. One with the 447 driver and the other 450, but it still didn't work.

  • Same problem :C

  • I had same problem. My firmware was quite old so I tried to start from older drivers (pre 402) but with no luck. So I tried other laptop - and that helped.

    Not sure if this is important for that issue but it is working on Intel based laptop but not on AMD (i5 vs Razen5)

    Looks like on my AMD machine, wheelbase - after switching to update mode - is not 'catched' by the Update Manager so firmware is not uploaded to wheelbase

Sign In or Register to comment.