Clubsport steering wheel formula v2

Hi all,

I'm having an issue with the above mentioned wheel,

I had the wheel and the base for 2 years now and never had a problem,

However today it started doing something weird,

When I attach the wheel to the base the base (podium DD2) display goes blank,the wheel display goes blank too and the wheel just start vibrating.

I have tried to restart my pc,uninstall and reinstall both fanalab and the drivers,

I have tried to run the driver repair from the fanatec control panel and I tried to downgrade from the firmware update page,all of these didn't work.

The only message I get while the wheel is attached is to flash the wheel firmware,I click on flash firmware it does the installation and then goes back to square one asking me to do the wheel firmware flash again.

On another note I have tried to submit a ticket to fanatec but after entered the product and the platform I get a message saying invalid token format and it doesn't let me carry on,

Any other way to contact them?


Sign In or Register to comment.