Big DD1 problem after firmware update

Hello guys, seems my DD1 has been bricked by a firmware update,

Happened during a race on iRacing (if that's a contributing factor at all)

After the update (it was during qualifying) I tried going back out and the steering was gone. Going back to the control panel I saw there were more updates but it just started hanging and giving me error messages.

I've tried everything on the troubleshoot instructions.

Seems like the motor fw is an issue. I have 42

Tried different USB ports, reinstalling older drivers (from 450 to 447), I always eventually get the ''No fanateac device found''on the control panel.

The only thing I wasn't able to try is rebooting the base, If I press down the power button the only thing that happens is the base shuts off. I never get an option to update the firmware. Only way to power up the base after that is to unplug and replug the power.

This is beyond my tech saviness.

Any help would be much apreciated !


Sign In or Register to comment.