DD2 not being detected

Hi I have a dd2 which isnt detected by fanatec control panel and fan runs at100

This started from a very unusual FFb i had and after doing an uninstall and reinstall of latest FW 450 it just isnt detected any more Any help would be most appreciated


  • I am having the same issue. Occasionally the DD2 will show up in windows as a game controller, but never detected in Fanatec Control Panel. I’ve reinstalled driver 450 multiple times with no fix. Fan stays running. It’s saying my base firmware version is 3.0.1 and motor firmware version 29.0.0.

    Post a reply if you find a fix


    1. Unplug all USB devices other than keyboard and mouse
    2. Unplug everything from the back of the DD2 (including torque key and e-stop)
    3. Turn off DD2
    4. Uninstall Fanatec Driver
    5. Reboot PC
    6. Reinstall Fanatec Driver
    7. Connect DD2 to a different USB port
    8. Start DD2 in bootloader mode (holding power button on the back for ~ 8 secs)
    9. Launch Fanatec Control Panel and follow prompt to update motor and base firmware.
  • Thanks for the response Markus but wheel base did go for RMA and returned. They supposably fixed it how ever it still doesn,t work and now i cannot get any response from Fanatec support.

    So after paying hundreds of dollars for repair and shipping and still not fixed i am a liittle disapointed to say the least

    It is still not recognised by fanatec control panel but fan is not running at 100 percent any more

    im hoping you can help me in some way as i am at a stand still at the moment

    Really frustrated with Fanatec

Sign In or Register to comment.