Install Wheel, loose connection

Received a new CSL DD wheel base today, original burned down after only 15 hours. Followed the instructions again and no connection to PC, tried another PC, 3 different cables, update, etc, all the regular stuff. After about 45 minutes of fiddling around I pulled the steering wheel off, and the base connected immediately, I then updated the drivers like normal, but when I installed the wheel back on, I lost connection and the steering wheel shows the symbol shown in the picture. After waiting for a month turnaround it's pretty damn frustrating.


  • does it worked without driver update?

  • Allan LehtlaAllan Lehtla Member
    edited August 8

    what i mean was that no error/symbol message at wheel before update?

    to you lost connection at time when you update firmware?

  • Olli RitaOlli Rita Member
    edited August 9

    It worked with the old wheel base, when I got the RMA for the wheelbase I asked them if I should send the wheel also, they said NO, and if I would send anything that they didn't give me an RMA I would have to pay for it, both ways, and they would NOT touch anything else except what was on the RMA. Their website says that due to increased traffic their support reply now takes 3-5 days, not very assuring how they handle business now a days.

    To answer your question, when I connected everything to my PC the app said "No fanatec devices found", only when I detached the wheel from the base it connected to the app, and I was able to update the drivers and firmware, then it asked me to connect the steering wheel, as soon as I did, I got the message "no fanatec devices found", so I'm afraid that when the original wheelbase went up in smoke, it also fried the steering wheel.

  • Allan LehtlaAllan Lehtla Member
    edited August 9

    you could look if some fanatec driver hid is disabled , probably could happen by powersave feature at windows self.

    or shaft is moved away.

    or try reinstall the fanatec software/drivers.

  • Software and drivers are installed more times than I care to count, sleeve was taken out and re tightened to specs @ 15Nm, all the screws were tightened in the back of the wheel. It is not software related, the wheel base does not need to be connected to PC and I get that little red squiggly line on top of the wheel as soon as it is connected.

    Can't even sell it since I don't know if the new wheelbase works.

    Fanatec's customer service has really gone down to shitter. Their website says expect answer for the ticket opening in 3-5 business days, the automated email I got says 7 days. So far I've been down for more than a month, sending one email a day for something that should have taken a week max. Return it, get a new one how hard is that? Took a week in between receiving the RMA number and shipping label.

  • i mostly know where that burn out may come, they have at devices those white big power resistor without any cooling

    either it blows up or device self shuts off. what makes players unpleasant experience when they drive

    my mesarue devise go nut as that resistor temperature rehash over 250c

    i'm assuming that thing could handle at some cases better where temperature is cold like in Alaska

  • the burnout/device shutdown fix is probably kind off easy fix and i not know why they not use this kind method for they product.

    they have there allot empty holes in they CSL dd body, they could just easy add that power resistor one off those and use also thermal paste,

    soo after that the full body could start cool this down

  • Yeah, I'm beyond interested in Fanatec anymore. We got a new steering wheel today (I paid for it), and it works fine on the "new, used, refurbished" wheelbase they sent me, just to find out the pedals don't work.... not interested in waiting another month for their less than crappy customer service to get me more stuff that doesn't work.

    250C is scary high, I guess I wouldn't be leaving anything on during, even a coffee break.

Sign In or Register to comment.