Fanatec CSL DD not showing up in device manager or fanatec software

I recently got my Fanatec CSL DD 5nm yesterday. The wheelbase turns on and I can use the wheel's(CSL P1) menus, but I haven't been able to get windows to recognize it. I've tried reinstalling drivers, firmware, swapping cables and usb ports, but I can't get it to work. All the videos and forums that I've found are where the wheel still shows up in device manager. Does anyone have any ideas? Thanks!


  • Just figured it out, I plugged the usb-c end into the wrong usb port on the wheelbase

  • I have the same problem but everyhing seems to be connected correctly

    I tried different USB Slots and changed USB-C slots

  • my dd pro wheel has ben working great for 6 months, now becomes unresponsive in the middle of a race.

    i tried rebooting and different ports, but no luck

  • fixed it, saw where someone said to make sure the wheel hub was pushed completely into the base.

    mine was out about 1/16 inch

Sign In or Register to comment.