inverted v3 pedals not recognized

I was doing a firmware upgrade on fanalab and the fanatec control panel and now my v3 pedals are not being recognized. I tried in another pc, and other usb ports. The pedals are connected straight to pc. The PC doesnt make a sound or show up in device manager that anything is being plugged in. HELP!!!


  • I have the exact same issue, I sent a message to Fanatec support and they asked for a video, wtf is a video going to do? The problem has not been resolved as of yet.

  • I've got the same issue...Clubsport USB Adapter to plug pedals directly to PC and now they're not recognized. At first it showed up as a shifter. Updated the USB Adapter with the correct driver and fair enough, there are pedal options - but only the CSL ones, have tried those and don't work. This is disheartening if you have Fanatec gear.

    Guess it's time to move on... Although, some help would be appreciated as I'm not looking to move to new pedals.

  • edited October 2023

    What pedals do you have? Many pedals must be connected directly to the PC without a USB Adapter.

    Currently only CSL Pedals without LC require USB Adapter. Or older pedals.

Sign In or Register to comment.