universal hub V2 xbox impossible connection

edited October 2023 in Steering Wheels


I had my equipment delivered yesterday.

After unpacking, mounting and updating all firmware, a problem persists

between the CSL DD base and the Universal Hub V2 Xbox.

Wheel Base:

Wheel Base Motor:

Steering Wheel: 2

Wireless QR:

I cannot access Console Mode, green light, the base only remains in mode

PC, red light.

I re-flashed the firmware, I do not use a USB extension cable, only the supplied cable,

but nothing changes.

I just opened a support ticket, do you have any ideas?



  • you sure you ordered ClubSport Universal Hub V2 for Xbox

    ? because there is also non xbox version

  • Yes i am sure.

  • Try switching modes using the buttons on top of the hub?

  • I have already tried all possible manipulations, even checking the tightening of the screws on the steering wheel pin side and pushing in the QR on the motor side according to the technical support's suggestions.
    So, I put everything back in the boxes and returned to Germany for reimbursement.

  • I just bought a V2 Xbox Universal Hub last week and I can't get it to work in Xbox mode either. Using on a DD1 PS4 base and two things are happening. Says on the DD1 it is in low torque mode and pressing ok does nothing. When the xbox is on and the wheel is connected, and you try and move the cursor around it just makes like a clicking mode and doesn't move. None of the buttons allow you to access anything. I tried hooking the hub to my podium button module endurance and it does the exact same thing. Everything is on the latest software and firmware.

    I contacted support last week and sent a video but have had no response. So now I am contacting customer service to return, this is obviously defective so if support won't reply then I have no other option than to return. Sucks because I really need the hub.

  • Just an update on my Universal Hub issue. My support ticket was replied to on Friday Nov 10. They asked a couple of questions and wanted a video again. So I sent what they wanted and they replied back this morning with another question. He asked if I had used the QR bolts that came with the Universal Hub or the ones with the QR. The ones that come with the hub are shorter. I had used the ones that came with my QR not thinking they were different. The longer ones can go in too far and damage the PCB. Well I changed out the long ones to the ones that came with hub and put everything back together. As soon as I connected to the Xbox I had full control and all the buttons work and the DD1 has full torque mode activated. I went into a game and everything worked fine. Luckily it doesn’t look like the PCB was damaged by my mistake. It took them a while to get back to me but once they did they got everything all sorted out. I am so relieved and appreciative of their help.

Sign In or Register to comment.