DD1 won't connect following firmware downgrade

To resolve another problem I created a new one: I downgraded my motor firmware and now my DD1 won't be recognized by Windows.

  • Coming from 4.51 I installed 4.39 and downgraded the motor firmware to V42 (yes I know realize this was stupid).
  • Base wouldn't be recognized anymore and fan at 100%.
  • I used the bootloader with the 8sec method to install the wheel base firmware to V691. This was successful but it is still not recognized in Windows. It seems to be stuck in calibration mode as CAL is flashing in the display.
  • I upgraded to 451 drivers but still not recognized in Windows. On turning the base on I do hear the USB connect sound, it just doesn't show up in the Fanatec control panel.

To summarize I have the following stats now:

  • Main: FW v691, HW v3
  • Motor: FW v42, HW v3, ACV v3
  • WQR: FW v6, HW v0

Hope someone can help me out of this :)


  • I have solved this issue. It turns out that in the Windows Device Manager there was a disabled input device. I turned it on and the wheelbase was immediately recognized by Windows and visible in the firmware updater. I have update the wheelbase back to 4.51, unfortunately my original problem remains.

  • I ran into the same problem with my CSL DD. It was pretty annoying since it just suddenly happened. I resolved it the same way.

Sign In or Register to comment.