CSL DD Compatibilty mode is missing from my wheelbase

Hi all.

I am really hoping this can be resolved. I have a CSL DD, with the BMW wheel. It only has the red and green modes, yellow (compatibility mode) doesn't exist. I've attempted pressing the power button multiple times but still it doesn't work, please help?

I want to try the wheel with rFactor2 but because I cannot switch to compatibility mode I cannot use the wheel with FFB.

Many thanks



  • What you indicate as "green" is actually yellow as the BMW wheel is not Xbox compatible and therefore does not enable an Xbox mode on the Base.

  • Jamie MarshJamie Marsh Member
    edited October 2023

    That's interesting as the wheel is sold on the basis that it is PC/Xbox compatible, isn't it?

    Do you know how I can make the FFB to work in rFactor2? I have tried multiple things in terms of the config file etc...

  • No it isnt sold on that Basis.

    It's sold as PC compatible and Xbox ready, meaning the base can work On Xbox if a Xbox compatible steering wheel is attached.

    Every BMW wheel Fanatec ever offered is not Xbox compatible.

    Therefore you only have the red PC mode and the yellow (or in your case greenish) PC Compatibility mode but no green Xbox mode.

  • Jamie MarshJamie Marsh Member
    edited October 2023

    Ahh ok I just checked again and your correct. Do you know anyway I can get the FFB working in rFactor2, on PC, using this wheel?

  • edited October 2023

    The RF2 FFB works with any steering wheel, so you can use the CSL DD in red mode. Try resetting and starting from scratch.

  • I have already done that. Uninstalled/reinstalled the software, firmware of the wheel drivers. Nothing has worked so far.

    Do you have any recommendations for me at all?

  • Try deleting previous command configurations on RF2.

    Enter a new configuration, and make sure the controller type is set to "wheel".

    Don't use the default configurations, they don't always detect the steering wheel, start a new configuration from scratch.

    You don't need to work on the Fanatec driver, you just need to configure RF2.

  • Jamie MarshJamie Marsh Member
    edited October 2023

    Is that from within the game or, from the directory files?

    To be clear the inputs work, I can turn the wheel, pedals work the issue is just with FFB - There isnt' any feedback resistance at all.

  • This should be able to enable FFB.

  • Thanks guys. I'll give this a go :)

  • Update

    It turns out that there may be an issue with my wheelbase. Compatibility mode is missing from it, so fanatec have started an RMA return. I will keep this thread updated in case anyone else has a similar issue.

Sign In or Register to comment.