Fanatec Control Panel hangs when CSL Pedal LC is connected via USB

Darren HayesDarren Hayes Member
edited November 2023 in Pedals

It occurred to me recently that as I've always connected my CSL Pedals (with Load Cell) via the wheelbase I'd never had an opportunity to check the version or upgrade the firmware on the Load Cell pedal.

So today I disconnected the pedals from my wheelbase and connected via USB for the first time. The pedals are detected correctly under Game Controllers in Windows 10 but when the pedals are connected via USB it causes the Fanatec Control Panel to hang. This happens 100% of the time.

I originally discovered this problem when I was on driver version 451 (with all relevant firmware current for that driver). I upgraded to the 452 release candidate today as well to try and resolve the issue but have had no success.

Any help much appreciated.


Wheelbase: Fanatec DD Pro 8Nm

Driver Release: 452

Wheelbase Firmware:

Motor Firmware:

CSL WRC Wheel Firmware: 4

Quick Release Firmware:

Load Cell Firmware: Unknown.


  • Can you please zip the whole C:\Users\Public\Fanatec Logs folder and send to us here with 452 installed and at least one crash happened?

    Also, please try:

    • uninstall current driver package on your PC
    • check if "C:\Program Files\Fanatec" still exist afterwards
    • if still existing after uninstall, delete it manually
    • re-install driver 452
  • Darren HayesDarren Hayes Member
    edited November 2023

    Many thanks for the response. Here are the logs. Doing a clean reinstall now of 452 also. Will report back.

  • Same issue. Clean uninstall (with reboots etc.) and reinstall of 452 made no difference. I've also tried opening Fanatec Control Panel with only the pedals connected (no base connected) and that causes the same application hang also.

    The hang occurs whether the pedals are already connected when Fanatec Control Panel is opened or if the pedals are connected afterwards - the behaviour is the same.

  • Ok.

    Next try:

    Can you also send us the following folder? Just copy-paste %LOCALAPPDATA%\Endor_AG_Fanatec in the File Explorer and press enter like this:

    Copy and zip all the content of that folder and upload here.

    Then Close Control Panel UI, delete all the content of %LOCALAPPDATA%\Endor_AG_Fanatec and try opening Control Panel UI if it still crashes.

  • I've cleaned Endor_AG_Fanatec and tried again. Same issue. Still hangs with USB connected.

    Thanks again for the assistance.

  • Then I run out of ideas and would point more towards a USB cable issue or something like that.

    Do you have a different USB cable you can try? Or maybe at least a different USB port?

  • Many thanks for the assistance. Good shout on the USB cable but I've tried a different cable and port already.

    This is very weird behaviour!

  • If I may, don't update the firmware of the pedals if you use them with wheelbase.

    Every time you flash the firmware you risk irreparably damaging your device if the procedure is not successful.

    Those are just pedals, they don't have motors and they don't give any kind of feedback. Updating the firmware will not improve the way they work. It's just an unnecessary risk.

  • edited November 2023

    Thats not entirely true.

    Every Pedal Firmware update, as rare as they might be, fixes issues or improves the overall behavior of the pedals. Otherwise there would be no need for a FIrmware update at all. For example the CSL Elite V2 Pedals do have a known Firmware issue where the BRF resets after every base restart. This will need a Firmware Fix which will come at some point.

    And Firmware updates are recently quite safe to do and not really risky, especially pedal firmware updates are totally safe, never read of anyone who bricked the pedals during a firmware update, those stories all come from Base Firmware issues (which in the meantime are also much more safe than a year ago as severalk measurements were taken to prevent the risk of bricking something).

  • Right I've solved it.

    I installed Fanatec Driver 451 on my laptop and Fanatec Control Panel on the laptop had no trouble detecting the USB connected pedals. I then used my laptop to update the firmware from v1.6 to latest v1.8.

    I then connected the pedals back to my sim rig via USB and now Fanatec Control Panel is working as expected and detects the pedals correctly. So on my system there was an odd quirk of Fanatec Control Panel not liking my pedals when they were on firmware v1.6.

    So I got the result I wanted - just had to go an odd way about it.

    Many thanks to Maurice Boschen for the assistance with this issue.

  • So currently I have my CSL with load cell connected to the base. Is the preferred method to connect via USB?

  • No, the recommended way to connect Fanatec pedals is to connect them via RJ12 to the base.

Sign In or Register to comment.