Clubsport DD base and WRC 2023 game compatibility

Hello everyone,

I am having a problem with the EA WRC 2023 game and my Fanatec base...

I have a Clubsport DD 8nm base and a Porsche 911 GT3 R Podium Steering Wheel, V3 crankset, Fantatec lever and handbrake!

Indeed, since purchasing the game, I have not been able to connect the steering wheel when the game starts, only the button to return to the main menu seems active.

I tried using another ClubSport Steering Wheel F1, it is recognized and the buttons work.

I sent an email to Fanatec to find out if they had had a problem already reported by other users, unfortunately I have not had a response to date.

I obviously checked the updates, everything is up to date.

I'm desperate, it's impossible to play this new game... :(

Thanks a lot for your help!

I'm really sorry I'm posting in the wrong place, but I don't really understand how new posts work...


  • You have a CSL DD, not a ClubSport DD as Nobody has a ClubSport DD yet... 😅

  • Is the game for PC, XBOX or PS?

  • I have nearly the same as you, mine is for Playstation.

    I too struggled to get it working, none of the buttons work on mine either.

    TO get the wheel to work I make sure it is on and the playsation has recognised it. I then start the game, then proceed to the controls menu and make the wheel your primary control. I think you need to select and edit, I have to do this every time.

    The standard settings are awful, I will try to post what I found and use this feels OK.

    The user interface is the worst I have come across and why they cannot make it work from the start is beyond me??

    The game will be OK when they finish it...

  • when fanalab is going to support a game that has fanatec branding in all stages, but we don't get telemetry!?

  • This or next month if everything goes well.

    The game just recently added UDP support in a post-launch game update and it seems to lack the ability to disable the native LED and Display support so it might need another game Patch first to add this Basic functionality in order to not interfere with FanaLab LEDs.

    PS: Fanatec is not a sponsor of the game and was not involved in the game development at all so Fanatec is not to blame for the lack of FanaLab support as it was just not possible at all yet to implement support for it.

  • "Fanatec is not a sponsor of the game"

    To further elaborate - Fanatec has a partnership agreement with the FIA WRC, (specifically with the M-Sport Ford team) and therefore I'm assuming EA/Codemasters are contractually required to represent the Fanatec logo and branding in-game, just as they would for Toyota, Hyundai, Ford, TW Steel, Asahi Kasei, etc.

    Fanatec no more had a hand in developing the WRC game than did Pirelli, for example. Though it is certainly understandable where the misunderstanding comes from, given Fanatec's reputation as a manufacturer of accessories for video games. It's not a huge stretch to (incorrectly) assume that they must have had something to do with the development of the game (or at least handed over a hefty sum of money) in exchange for seeing their logo dozens of times in every single stage of the game.

  • edited November 2023


    There is no direct sponsoring between EA WRC and Fanatec.

    And no, Fanatec did not had anything to say in the games development and was not involved at all. Dont think they even got codes for the game in advance of the release as the lack of UDP support at launch was a surprise for everyone.....

  • "FIA WRC is NOT EA WRC."

    I never said that it was...? That's why I made the distinction and said Fanatec's agreement is with the former, which is why Fanatec's logos are required to be seen in the latter.

  • Thank you very much for your help, I will try again to do as you told me Braking_Badly, but I seem to have already tried, it didn't work...

  • Game update 1.3 just dropped yesterday, I believe it was. I remember reading in the patch notes that there were a lot of fixed issues that specifically pertained to different models of Fanatec wheels not being recognized or not being able to navigate menus.

  • Unfortunately this doesn't work either with the latest update...

    In fact the most surprising thing is that when I am in the command menu, the steering wheel is well recognized and all the keys react well :(

  • Thanks for the answer i will wait the next release then

    and many thanks for your profiles by the way

  • I had a similar issue when the game was first released, with my McLaren v2 wheel. Everything worked fine in game, but I couldn't use the wheel for menu navigation.

    I found a solution on the EA forums, it involved editing one of the game's xml files to add the functionality. Sorry I don't recall the specifics (away from my PC right now), but maybe that can point you in the right direction? Good luck.

Sign In or Register to comment.