Updated firmware to version 454 and everything quit working

Hi there, Pretty new to Fanatec products, but everything was working great until we tried to install the 454 firmware update, now it doesn't recognize anything is connected. I've uninstalled and reinstalled the drivers & firmware 3X, changed USB ports, powered off, updated from the C:\Program Files\Fanatec\Fanatec Wheel\fw folder. I've opened a support ticket, but totally frustrated, please help!! BTW we have the CSL DD 8nm, ClubSport Steering Wheel RS, ClubSport Pedal V3 and ClubSport Shifter SQ v1.5 The pedals are connected to the DD and the DD is connected to a Windows 11 PC via USB cable.


  • your message is unclear , you tell nothing working but you was able install firmware 3x

  • It doesn't recognize that anything is connected to the computer

  • I assume it either an issue with the 454 firmware update or possibly related to a Windows update, I highly doubt it's a hardware issue

  • Dustin GDustin G Member
    edited November 2023

    Wheelbase is defo set to pc mode and not PlayStation mode? ( sorry I read that you had the DD GT)

  • why you todo that?

    C:\Program Files\Fanatec\Fanatec Wheel\fw folder

  • Just to note, I see people in the pedals section saying since driver 454, things have stopped working for them, sounds like driver 454 is perhaps buggy, they also could not get things to work rolling back the driver,

    dosent sound like it’s just you having issues.

  • i to have the CSL DD 8nm, and for me is unclear why he is used folder tools manually. this firmware update stuff is all automated by default

  • Hit the windows button and search for device manager. Expand the human interface devices tab and one of the drivers will be disabled due to the update. Reupdate your firmware to version 454 and enable the driver that was turned off, this should get everything working again. Not sure why this update does this for some people but it worked for me.

Sign In or Register to comment.