CSL DD Pro + Esports Wheel Issue

So I'm having an issue with a used wheel I recently purchased. When I put the wheel on the base it disconnects the base and the power light pulses red and won't be recognized on the control panel until the base is restarted. My original wrc wheel works totally fine. I've restarted everything. Uninstall and reinstalled everything fanatec and updated everything. Anyone have any ideas?? Also I have tried removing the shaft of the base and reseating it and torquing the clamp.

Link of a video to show what’s happening. Thanks in advance for any help!!



  • shaft could be lose but not 100% sure because it only blinks red light

  • That’s what gets me to. I can’t seem to find what the pulsing or breathing red light means. And it wouldn’t make sense for other wheels to work without any issues if it was a shaft/base issue I would think. I’m going to open up the wheel in a little bit and see if there’s anything obviously damaged internally on the wheel.

  • Not to mention that 2 years ago, therefore in a very different period from today, an RMA with Fanatec lasted a whole month. I had to use the Logitech G29 for a month instead of the Fanatec wheelbase. Today assistance responds in 2 weeks. DO NOT UPDATE DRIVERS AND FIRMWARES.

  • Why do you say not to update? I’ve always kept mine up to date.

  • Updating firmware on any device should be done with caution, since any mistakes or missteps can lead to the device becoming inoperable.

    When it comes to Fanatec, if something goes wrong and you wind up needing customer support, you're currently looking at approximately a 2-week wait just to get an initial reply to your request. This will likely be followed up with a request for more information or pictures/ video which you will then need to supply, and then wait another 2 weeks for yet another reply. If you're lucky, this will then be followed by at least a week's wait to ship your item to their warehouse, a few days for them to assess the problem, and another week for them to ship it back. Therefore you're looking at a couple of months, minimum, that you'll be sitting around and unable to enjoy your hobby, unable to use this expensive Fanatec equipment that you paid for.

    If your Fanatec devices are currently working, leave them alone. Fanatec do not thoroughly test their drivers and firmware before releasing them to the public, and it is often the end user who suffers the consequences of unforeseen bugs, incompatibilities, or other broken features as a result. They constantly push out updates as a result of this, in an attempt to fix things, but things are constantly in a state of flux.

    If it's not a critical update for security purposes, or something which needs to be updated to maintain compatibility with other devices, you're generally better off leaving things alone. Fanatec firmware updates never, as far as I'm aware, fall into the former category and only rarely in the latter.

  • Sorry, I posted the comment in the wrong topic. I was commenting on the bricking of the pedals after the firmware update, and I posted here instead. Things that happen to boomers, I suppose.

  • In any case, yes, you should not update the firmware, especially when customer service is non-existent.

  • Got it.

    So does anyone have any idea on the problem? Lol

  • A guy had the exact same problem and solved it like this. However he only had one wheel. I can't think of why it would work with one wheel and not with another wheel.

  • edited November 2023

    Are the pins inside the QR in the same position as the WRC steering wheel?

    Do both steering wheels have QR1, or does WRC have QR1 lite and does the Formula steering wheel have a metal QR1?

    Try swapping the QRs between the two steering wheels.

  • Yup pins are the same between the two wheels. Also both wheels using the metal QR1, I had an original formula wheel with the permanent qr1 that also works fine.

    I opened up the wheel in question this morning to assure pins were all connected to board and nothing looked obviously broken. (I disconnected the white plug that goes to the pins)

  • can you take closer photo from that microchip, there something weird at there but not sure

  • Unfortunately I can’t right now, but I also noticed that and meant to take a picture before I put it back together. It has a strange yellow/greenish smudge coming from that hole. I tried gently wiping it off but it did not change. Nor did the “smudge” wipe away. I zoomed in on the picture to see if it is easier to see but I’ll open it back up tomorrow for a better picture.

  • it could be that socket yellow shit what they use hold those cables and someone split to there

    also this is little weird

  • Here are some better pictures of the internals.

  • Allan LehtlaAllan Lehtla Member
    edited November 2023

    i not see anymore that thing at cr200, what it was ? i really hope it was not some metall thing because something like this could burn something down

  • It was a little plastic thread from one of the covers that has the course screws that just go into plastic.

  • So safe to say no one really has any idea for this?

Sign In or Register to comment.