Clubsport pedals not detecting PC or wheel base

I purchased my Clubsport pedals late 2022 and have recently been having issues with connections between the Clubsport Pedals and my wheelbase (Podium DD2) It started out as simply the accelerator would drop out for 30 seconds and then reconnect But now it has fully lost all connection via the RJ12 ports and the USB connection to my laptop. however, if I use the same RJ12 cable for the Handbrake ports it works perfectly. I really am stumped on what the issue could be..

My attempted fixes include,

  • Cleaning the ports
  • testing the RJ12 Cable (no issues)
  • changing back to old drivers and downloading the latest versions
  • testing to see if the laptop recognizes the pedals alone on device manager (it doesn't)

Anyone had the same issue? I've raised a ticket for it today but I have a strong feeling there's a damaged port somewhere.


  • Have you tried connecting the pedals directly to your PC via the included USB cable?

  • I think you're probably right about the port, but also make sure you only have the RJ12 or the USB plugged in.

    I'm sure you already know that based on your troubleshooting so far, but it's also a weird setup and i always found it cumbersome for updating firmware etc. Enough that i searched if it was ok to do that and there is apparently lots of issues with users breaking the pedals that way.

  • Hi, Yes I've connected them, device manager doesn't detect anything being plugged in and you cannot hear the audible tone.

  • Yeah its defiantly been an issue that doesn't seem to want to resolve. I will hopefully be able to send back for repairs or just have the board replaced completely.

  • Based on what you have done, I would say the PC control board has failed in some way.

  • So update,

    I have unscrewed the board from the pedals to test with a voltage meter When testing through the USB and RJ12 (not the same time) but are receiving a power signal fine and transferring it to all necessary ports ( Brake, Clutch and accelerator) I am unsure as to why my laptop or wheel are not picking up a signal on their end..

  • Further Update,

    have somehow been able to connect the board up by USB for a very short period before dropping out again, I was able to collect the program log I am almost 50 lines of


    CSPV3_LOG: Erase Started (may take several seconds)

    several lines of;


    Any computer whizz out there able to solve this mystery ??

  • Been a full week and still nothing from fanatec its a disgrace that they take this long.. I was able to recconect the board again for 4 mins and again pull the log if this means anything to someone and can debunk my problem you would be a a legend!

  • Jon KramerJon Kramer Member
    edited January 24

    Make sure the PCB is grounded to the frame of the pedals.

    Wedge a coin between the metal PCB plate and the cross bar of the pedals below it and see what happens.

    It could be a grounding issue.

  • nah no luck, screwed it all back in and getting nothing

  • Hello All,

    @Mason Swandale, have you succeed on this matter?

    I am 1 week waiting for a reply to my RMA Request but I am having the same issues as you (although can only have it connected for about 30 sec).

    I have tried different laptops in several USB ports and also connected to DD2 directly. And I cannot have it plugged.

    May anyone able to help on this?

    Thank you very much

Sign In or Register to comment.