CSL Pedals from the CSL DD ready2race bmw bundle not working

I bought a csl DD ready2race bundle and i can't for the life of me get the pedals to work

They are connected through the base, the wheel works great, all the buttons and FFB works it's just the pedals that does nothing.. tried to connect the base through different usb ports on my PC still nothing

I've reinstalled the drives multiple times, tried with some old, some new. nothing worked.

I've followed the official video guides, tried doing it multiple times aswell.

This is what it looks like in software, nothing happens when i press any of the pedals.

If they are plugged in to the base i can't hide the pedal tab, so the base can see them but thats it.

All firmware is up to date. if i look it up in device manager this is what i see

I've also tried to measure the rj12 cable and it's fine. so i'm totally out of ideas and i just wanna race :(

Has anybody tried anything like this and found a fix?


  • The solution is to open a ticket with technical support.

  • Ohh yeah forget to add that I've already opened a ticket but it's not to fastest respond time so I hoped some had a clever trick I could try in the meantime

Sign In or Register to comment.