CSL WRC Elite and Podium HUB Not recognised

Hello everyone,

During the past weeks it happened to lose force feedback during gameplay but, by restarting the base, the issue was always solved.

Few days ago the issue appeared but no restart fixed it.

When going on the Fanatec control panel the wheel tab is blocked and no wheel seems recognised, same when trying to do an automatic wheel firmware update.

If I try to manually update the wheel firmware (in both Csl WRC and Hub) the procedure is succesful and the system informs me that firmware is updated (it correctly recognise the hardwares in the manual firmware update prompt) but the result doesn't change in the Fanatec control panel and in game, both hardwares remain unseen by the system.

I've also tried to flash all drivers and install them back, and to install previous drivers but nothing.

Fanatec drivers are updated to latest version i could find (455) and Both motor and base firmwares are up to date. I'm using a Clubsport 2.5 Base.

Contacted support but never haven't got an answer so far, anyone had same issue or has any advise?


  • experiencing the same problem right now everything was working fine yesterday and now out of nowhere this is happening I get this update that just keeps coming up with both of my steering wheels I’ve tried reinstalling the older and current driver cannot get it to work again believe there is a hardware failure it seems bricked I sent information to fanatec I hope they help me even the handbrake lasted a couple days the potentiometer sensor was very erratic and they unit broke multiple times and ways I ended up having to replace it with the Moza handbrake this all happened in about a year

Sign In or Register to comment.