DD+ Connection Lost while Firmware Update

Today I received my DD+ and it works fine on PlayStation 5.

I started with recommended updating firmware.

I tried driver 455 (both releases) and 454. I tried different USB ports. Everytime same behavior:

As soon as I start Firmware Updater USB connection is lost. The software is „Waiting for USB reconnection“. I tried several times and even waited for +40 minutes.

Fanatec Firmware Manager is not responding anymore.

In this state wheel base cannot be turned off nor mode cannot be changed. Reconnecting USB wheel bases is not recognized neither Windows nor Fanatec Control Panel. Power has to be turned off (power supply cut off) for wheel base to be recognized again.

Everything else works. After failing Firmware updates several times wheel base still works on PlayStation and is recognized by Fanatec Control Panel. The only thing that doesn‘t work is updating firmware.

Windows 10 Pro 22H2

Wheel Base Firmware (Starting Point) 2.0.0.17

WRQ (Starting Point) 0.6.6.5


Comments

  • Update [Problem not fully solved]

    I tried again with a different approach:

    I started the Firmware Update and lost USB connection; cut off power supply while not closing Firmware Updater. I turned on the wheel base again; USB connection established. Next failure…

    I rebooted the wheel base as prompted (this time wheel base responsed to power button). USB connection was established again. As nothing happened for several minutes I clicked on Flash Firmware button. FirmwareUpdaterEufe.exe instantly stopped working. Had to close it.

    This time Quick Release update was successfully conducted and I was asked to center calibrate and set gears of attached gear shifter.

    I tried the whole process again without any accessories attached hoping with updated Quick Release it might work. No difference. Exact same behavior.

  • ScSc Member

    sounds like something is cutting off usb connection. Can you try to use another usb port oder maybe another pc?

  • I tried different ports but don’t have the option of another PC…

    USB connection only gets cut off when firmware updater for wheel base. In every other case USB connection is stable

  • ScSc Member

    ok that is strange maybe there’s a conflict or firewall is blocking updater but I’m no expert.

    Would try to borrow a laptop from a friend and if the issue persists contact support

  • I hope one of the technical experts of Fanatec will look into my diagnose files and tell me what could be wrong.

    but it looks like it‘s either a driver issue and/or a ClubSport DD(+) issue because other have similar problems to update their wheel bases

  • ScSc Member

    yes I guess that’s the best you can do now. Hope that’s only a driver issue and can be sorted out quick.

  • MadDog-ICMadDog-IC Member
    edited February 13

    That diagnostic log file is too old (2 years ago) and only references a CSL Elite PS4, no mention of a CS DD+, Upload a current version dated in 2024.


    Generic Advice to try:

    1) Try another high quality USB cable with a direct connection between Wheel base and computers USB.

    2) Try using "Windows Device manager" to disable all "Power Management Features" so it looks like:- "Allow the computer to turn off this device to save power = Unticked" on all "Generic USB HUBs" and "USB root HUBs".

    3) Seems to be a trend with other CS DD+ having similar issues to yours, so may just be a FW / Driver or Hardware problem that only Fanatec can resolve.


  • Marcel JeskeMarcel Jeske Member
    edited February 13

    Thank you. I uploaded a wrong diagnostic file. This one is correct:

    I tried different cables including the original one.

    The DD+ is not recognized in Hardware Manager as your wheel bases/ wheel base related hardware in the image file. It‘s just a couple of HID (Human Interface Devices) conform devices.

    I ticked off all the checkboxes of USB-Root-Hubs and Generic Hubs.

    Still same behavior.

    I updated all my Fanatec Hardware (including a DD Pro) 2 days before with the same setup without any problems.

    Quick Release Update of DD+ was performed successfully after Firmware Update failure. As soon as I try to Flash firmware the Eufe.exe stops working.

  • Here is an expanded view of Hardware manager with the needed "View options set - Devices by container & Show hidden devices".(Devices by Container = Organises devices nicely, (Hidden mode shows all things currently not active (Ghosted icons), but have been used / active on your system before, it also shows all things active (Dark Black icons).

    When and if you can get your CS DD+ to show in the Fanatec's Device driver, cycle the CS DD+ Modes from PC -> PC Compatibility -> Playstation -> Playstation Compatibility -> Xbox if applicable.

    As you cycle the modes of your CS DD+ with the correct button combo on you wheel, each mode should be detected and the devices loaded and made active in the "Windows Device Manager -> Fanatec" sections, take note when in PS or Xbox mode the devices will disappear from the "Fanatec's Control Panel" and just say it is in PS or Xbox mode.

    If the mode switching isn't working as described above, I would have to say there must be and issue in the CS DD+ as you stated your other wheel base works ok or your windows setup some how has a problem only with the CS DD+ install, either way I would be unable to help much more and you may have to RMA to Fanatec.

    You stated that you got the WQR updated, but logs show that is not the case unless you did it after you posted the log files (WRQ (Starting Point) 0.6.6.5) only showen.

    I could hypothesize that the previous installs of other Fanatec Wheelbases such as the CSL Elite PS4 and CSL DD Pro might work against each other under specific circumstances with the CS DD+.

  • Thank you again. I changed the view settings in Hardware Manager and it looks similar to your image now.

    I erased all of the Fanatec Hardware to try a complete reset; uninstalled Fanatec Control Panel and Fanalab. I used several Software to get rid of any traces in registry etc.

    Starting from scratch I installed Fanatec Driver first but didn‘t open it. I connected DD+ to PC and turned power on in PC mode. Windows notified me about driver installation. After being notified about successful driver installation I started Fanatec Control Panel and Firmware Updater. Still same behavior:

    As soon as I start the Firmware update of the wheel base USB Connection gets lost after UpdateRequest response = wait. After power cut off, power on USB Connection is established. SetParameterRequest response failes. FirmwareFlash failes. I shall reboot the wheel base. After reboot USB Connection is established again. As soon as I Click Flash Firmware button FirmwareUpdaterEufe.exe stops working.

    The first time I did it that way (2 times reboot) Quick Release Firmware Update was conducted successfully.

    So, these are my latest Log Files:


  • I have the exact same issue. 100%. On a Clubsport DD.

    Fanatec, please help. I have tried with driver 455 and 454.

  • Obviously it has to be a bug somewhere that causes the "FirmwareUpdaterEufe.exe" to lose the USB Connection when trying to program the FW, but for the life of me I am out of ideas as to what it could be.

    One difference between your other DD bases and the CS DD+ are the others only require USB2.0 whilst the CS DD+ supposedly requires a USB3.x port.

    I would expect "FirmwareUpdaterEufe.exe" to lockup after you power off the base / motor, because that would take the base out of the required programming mode (Bootloader mode) and place it back in normal operation mode.

  • Thank you for all your help.

    Well, I need to wait until I get a response from a Fanatec expert.

    If none of them notices this thread or my identical post in Driver 455 thread and it will kot working with the next driver I‘ll have to create a ticket.

    At least the wheel base basically works but seems to not like my shifter signals

  • Received my dd+ yesterday and so far it's been working okay with my ps5 with the stock base and qr firmware. However, whenever I hooked it up to my PC to upgrade the firmware, it gave an USB connection error for the base and unknown error for the QR. At this point, I hope it's a fanatec driver issue and not any hardware issue and I am extremely reluctant to send fanatec my hardware knowing how long it took them to ship my unit in the first place. Driver 455.

  • I am having the same issue, waiting for USB reconnection. Did you find a solution yet?

  • No solution found… I asked Maurice in driver 455 thread. He also had no idea what could be causing the issue. He recommended to contact Customer Service.

    I‘m going to wait for the next driver before getting in contact with customer service. But I‘m not confident the next driver will help. I tried driver 454 and it showed the exact same behavior.

    Maybe I‘ll find someone with a different PC/ Laptop to try it on another system.

  • I got mine to work, I disabled my firewall, and had my steering wheel on the base ( I didn’t have the wheel on the base when I was having issues and do not know if it had anything to do with my problem)

  • Thanks.

    I deactivated my firewall(s) and tried wheel base with and without every wheel I have (BMW M3 GT2, BMW M4 GT3, Formula, Podium Hub + Podium Button Module Endurance, Podium Hub + Podium Button Module Rally) on both drivers 455 and 454. Still same behavior.

    But maybe it will work for some of us having this issue - at least it worked for you.

  • That’s too bad, the only other thing I can think of that might have changed is when I initially connected the base to the PC I had the Fanatec software running but, the base was in PS mode and the software had me switch the base to PC mode.

  • It finally worked!

    Long story short: it appears to be the original cable needs to be plugged in directly into PC.

    Because my SimRig is far away from my PC I used to use an USB 3.0 extension which has always worked with my DD Pro before. I needed to dissemble my DD+ from my SimRig to get it close enough to the PC.

    I erased all Fanatec hardware from hardware manager. I uninstalled Fanatec Control Panel. Several restarts inbetween to make sure to start from scratch. I also cleaned my regsitry just in case…

    I powered on DD+ in PC Mode. I plugged in original Fanatec USB cable to a USB 3.0 Port of my mainboard. Driver was successfully installed. Wheel Base appeared as Gamecontroller in Hardware Manager (as container). I installed driver 455. I has to restart my PC. Wheel Base still plugged in and powered on. After restart I opened Fanatec Control Panel and started Firmware Manager. This time it ran through. It showed several USB disconnections but reconnected successfully again.

    So possible causes might be:

    • wrong cable (even original Fanatec DD Pro isn‘t working)
    • not directly plugged in PC
    • not plugged in USB 3.0 port
    • incorrect order of driver installation


  • Thanks for updating here, I went through the same thing and the solution was using the supplied USB cable and retrying until everything worked. Initially I connected my GT Extreme to the PS5 and ran a test race. Worked okay but FFB was a bit subdued. Went into settings and it was seriously broken. Half the time button presses just ignored, would just flash when I tried to update anything and refused to exit the settings menu.

    So I started the firmware update and got the message above about waiting for USB reconnection. After changing the cable it started doing automatic driver updates ... and kept doing them ... and kept doing them ... Finally I just rebooted and reran Fanatec Control Panel. That threw a message about needing to repair the driver and then reboot ... did that a few times and finally was able to start the driver update but it got to USB disconnected ... USB reconnected and no further. Restarted everything and when I reran it said it was in the middle of an update and needed to continue so I clicked okay and it updated the base.

    Then it lost connection with the wheel. At some point it showed 1.03 available for the wheel (currently 0.0.0.0). Another round of restarts and the wheel came back and was up to date on firmware. Now the settings menu on the wheel worked as expected, was able to adjust everything fine and exit. Started a test race and now the FFB was full on working and the telemetry was displayed correctly (only speed for GT7) but was a white screen previously.

    So about three hours of try, reboot, repeat ... and success. Welcome to life with Fanatec.

  • At least it‘s just been one single day with three hours… I had that expierence 8 days in a row until I found a solution 😅

    But to be fair, in the last almost 12 years I never had issues with fanatec hardware. Everything has worked fine out of the box.

Sign In or Register to comment.