CSL DD power button stopped working

While I was playing Dirt rally 2.0 the buttons stopped working although the wheel was still turning. I closed all programs and restarted the computer.after that the computer recognises all hardware from fanatec control panel or fanalab but it's stuck in PC mode. Red power button. I checked all the connections and made sure the shaft was properly in and tightened for QR etc

I can't change to another mode like compatibility mode. When I press power button for a long time it doesn't power off. It doesn't seem to be doing anything. I had to disconnect power cable to turn off. Have uninstalled firmware and revert to older 452. Still no joy. It would check ffb test and centring all ok. When I do tuning menu from the wheel LCD shows LOCK or LOC and can't change to other profile nbers 2,3,4 etc

BTW I've tried with GT3 v2 and CSL universal hub v2 wheels. Has anyone have had this issue? Any help greatly appreciated


  • Common problem when you update to Fanatec driver v455 and corresponding FW for base and wheels.

    Rolling back driver v451 and previous corresponding firmware for wheels has approx a 50% success rate, other times there is a fault with the CSL DD it self or the QR shaft connection with the USB-C inside the motor shaft (some times the USB-C plug is actually damaged, other times it has just slipped out enough to cause weird issues, such as losing FFB and buttons whilst racing".

    Current driver v455 and FW for CSL DD, P DD1 / DD2 bases lose XBox mode and motor power button can't change modes or turn on or off properly, I believe Fanatec are investigating this and hopefully release a new driver or FW updates to remedy it.

  • Thank you so much for your reply ,🙏 I'll try to roll back to 451 when I get home. Hopefully it is the case.

  • I was able to fix it by going back to 451, thanks again for your suggestion MadDog-IC . I also made sure the wheels are not connected when I was flushing the FW for the motor and base.

  • that power button thing may come if you maybe accidentally click NO if fanatec asked klick Yes, but im not sure

  • Nice to see you up and going again, well done.

    About disconnection the steering wheel when updating the base FW is excellent advice, I keep forgetting to mention that on the assumption that every one knows to do that, My Bad ;-).

  • I'm not quite sure what it was. First I thought it may be the physical button but I realise I could turn it on with the button so it can't be the button itself. But I'm so happy it's fixed now. Hopefully it'll be helpful for someone else too 😊

Sign In or Register to comment.