PBME Error : Wrong version in firmware updater and AJ stick seems to be not calibrated


I have some "problems" with the Podium Button Endurance Module.

I have updated it since the first day with driver 455 (I have DD+ base and a podium hub associated) and everything seems to be fine during the process.

But now 2 problems occurs :

  1. Firmware updater always says to me that I need to update the PBEM to the new firmware (although it is already updated) and when I proceed to update anyway it does not succeed and my wheel is not anymore recognised (unless I turn off/on the base)
  2. When I try to use the wheel with the PBME or try to check button in the fanatic tool everything seems to be working except for the AJ stick which is always by default on the up/right (but physically ok/centered). When I use the button it get entered again until the next boot of the base.

Could someone help me ?

Thank you


  • Exactly the same thing happens to me. And it seems that the solution is RMA and sending the base back to Fanatec.

  • Update : I have noticed that each time I push the Tuning button the AJ stick is then set at random position...

  • I have the same problem but no one is answering me.

    My Button Module Endurance stopped working (bricked) 4 days after I updated the Firmware (455) on the Podium Hub and the PBME. After trying multiple things, I switched the Podium hub to another one I have that I had not update yet and that fixed it until it stopped a few days later again. After this happened, I updated the wheel base to 456 but when I tried to update the Podium Hub that was not updated, it stopped half way. It starts the update but it does not finish the update. The power light switches from red to blue in the middle of the update by it self. I tried to update it a few times already and the same thing happens. What is going on? No word from Fanatec yet. email sent to Fanatec March 18th

Sign In or Register to comment.