CSW 2.5 Stuck in Update MOde

Hello, just wanted to update Base and Wheel (Clubsport Steeringwheel F1 2020). In this process i got a message that the process failed, now the base is unresponsive in the firmware update mode (flashing blue) and i cant get out of this mode. Anyone had this problem and can help me? Its not even in the Device manager anymore. Already tried plugging in into another usb hub, holding the on/off button for 10 sec but nothing.


  • Allan LehtlaAllan Lehtla Member
    edited March 24

    if you hold button 10 sec then it indeed stays in blue mode, you understand that this processes by default should not be used at all?

    is there something not worked at V439 that it force you try 455 version instead?

  • Can someone make me understand how even the older bases like the CSW v2.5 and Podium DD's are getting Fucked up by software updates? Not to mention brand new bases. Did a disgruntled exe employee sabotage the software or was the code a victim of a cyber attack?

    Isn't Fanatec responsible enough to pull a update when it is obvious this is happening?

    I bought a PBMR and don't want to risk bricking my DD1 to recognize the newer part. So there it sits unused.

  • have no idea really, thing is. they know that there is issue at they some older hardware. why even allow update the firmware for that specific models

  • What? There is no known update issue on older hardware!

  • Allan LehtlaAllan Lehtla Member
    edited March 24

    Maurice Böschen

    you self tell that there is in sleepy hardware bug in old DD1 and after firmware update that specific models needs a repair because it will be damaged

    and that comes the thing. fanatec knows that so why even allow updates for that specific hardware first place

  • edited March 24

    This thread is about a CSW V2.5 and not a P DD and the sleeping hardware issue of the P DD only affects a fraction of units, it's very minimal. So of course we will not force an update stop for the still supported P DD lol when 99,75% of the bases are unaffected by this.

  • Sorry Antonius,

    You said your base is plugged into a USB hub? Did you mean a external hub? If so is it powered? I use a Orico 4 port 3 amp powered USB 3.0 hub myself for a DD1, pedals, and shifter and never have connection problems.

    You seem to know what your doing and that's why I place the blame on the software. Hope you don't have to send it in if perhaps base recovery software is offered.

  • Jack PickettJack Pickett Member
    edited March 24

  • firmware updates should never be made if the hardware is connected to a USB hub, to be on the safe side it should always be connected directly to the PC

  • I was just trying to determine if that's what HE did, not a recommendation to others. Because don't see anything he did wrong otherwise.

    Anyways try this on YouTube...


    This may solve your Device Manager no show issue.

Sign In or Register to comment.