PS5 instant disconnection CSL elite plus


i bought a CSL elite plus wheel base on eBay and use it with a P1 V2 wheel. It works normally with GT 7 on a PS4 Pro. However on a PS5 when I try to connect it, the wheel base disconnects after under one second while i am in the game. On the dash board it is connected longer but disconnects as soon as i turn the wheel somehow.

Anyone got an idea?


  • try a different usb port? what driver/firmware is it running? it might be too old for a ps5?

  • Hi.

    I tried a second usb and had the same problem.

    Drivers are up to date according to the fanalab software. 600 something for wheelbase and 22 for the motor.

    Or can I maybe install an older driver to see if the problem vanishes? Not sure this is possible via fanalab?

  • If its 693, then you should be fine.

    are you using any USB hubs or extensions? some people have said they use the USB port on the back of the ps5 and that worked better?

  • I think it is 693. it is the latest.

    I can try the other USB port at the back. At this time I tried 2 out of 3 USB A ports. There are no hubs or something connected.

    I did not successfully use it on pc but only tried Dirt Rally 3 from 15 years ago. I will today try out Dirt 2.0 from 2019 and see if it works.

  • So it works on PC with Dirt 2.0

    However is it normal that the automatic ffb is almost 0?

    I have to manually increase it on the wheel. At 100 it's pretty strong though.

  • ps5 does not support CSL elite

  • Really? There are youtube videos that show these are compatible.

  • Sorry, the base actually works on ps5 too. It seems that the game doesn't like the steering wheel when it only turns off when you turn. What happens if you turn on the game without the steering wheel on the base?

  • The wheel also turns off on the dashboard as soon as you turn the wheel most of the time but not always. However it just stays connected for 0.1-15s. Most of the time the 0.1s.

    When I switch it on while in a race, i can use it for 1s or so before it turns off.

    I cannot connect the base without the steering wheel because you have to push the connect button on the steering wheel. Otherwise it is not connected.

    Might be a problem if the P1 V2 though. I have no other wheel to check it.

  • Btw I checked all usb ports and used a new usb cable with gold contacts but it does not change.

  • Can anyone with a CSL elite plus check if it works for him on a ps5? If they have a P1 V2 even better. Maybe the wheel is the problem?

  • I solved the problem.

    Connecting the racing rig fixing screw to the wheel base with a self made cable to the electronic ground of a power plug.

    No disconnects at all. So it was a mass loop something problem.

Sign In or Register to comment.