Clubsport DD Firmware Update Wheelbase not Working

Hallo Guys, i really tried too Update my Whellbase Firmware but every Time i tried the Wheelbase disconnects und need a Restart with disable the Power. After this its reconnects and the fun begins at the start with disalbe power to reconnect the Base. The Steering Whell an the QR Update runs without any problems. i put the screenshot an the Log-data. so i hope anybody can help me with this problem.


  • I had a similar problem and finally found a solution. I created a thread about this topic and posted what worked for me. This is the post:

    „It finally worked!

    Long story short: it appears to be the original cable needs to be plugged in directly into PC. 

    Because my SimRig is far away from my PC I used to use an USB 3.0 extension which has always worked with my DD Pro before. I needed to dissemble my DD+ from my SimRig to get it close enough to the PC.

    I erased all Fanatec hardware from hardware manager. I uninstalled Fanatec Control Panel. Several restarts inbetween to make sure to start from scratch. I also cleaned my regsitry just in case…

    I powered on DD+ in PC Mode. I plugged in original Fanatec USB cable to a USB 3.0 Port of my mainboard. Driver was successfully installed. Wheel Base appeared as Gamecontroller in Hardware Manager (as container). I installed driver 455. I has to restart my PC. Wheel Base still plugged in and powered on. After restart I opened Fanatec Control Panel and started Firmware Manager. This time it ran through. It showed several USB disconnections but reconnected successfully again.

    So possible causes might be:

    • wrong cable (even original Fanatec DD Pro isn‘t working)
    • not directly plugged in PC
    • not plugged in USB 3.0 port
    • incorrect order of driver installation“
  • Thanks Buddy! It was a USB 2.1 Port not the 3.0.

    THX so Much

  • There really needs to be a USB 3.0 or greater hardware check in the Fanatec software/firmware BEFORE it allows you to continue.

    To many customers are being tripped up, causing some to brick their damn wheelbases unnecessarily.

Sign In or Register to comment.