Power button not working fully and other functionality issues

Whenever I press the power button to turn the wheelbase on, it works perfectly fine. However once the wheel is on and I press the button to change platform modes it doesn’t work. I’ve tried using the specific combination on a wheel to change modes but that didn’t work either. I can’t turn off the wheel from the button either. I have to resort to pulling the plug out to turn the wheel off. Also I have lost functionality with the wheel itself. I can’t change to different settings. I am stuck on SET 1. Also on the display, when I am driving there is a decimal point that moves horizontally across the screen every so often. So my speedometer reads 300. , 30.0 or 3.00 for example. Lastly, because I am stuck on PS mode and cannot access PC mode, I cannot update the wheel or anything like that. I’ve tried contacting technical support by opening a ticket but when I press submit, it says I need to enter a subject and a message even though I already have.

Please help me!

Sign In or Register to comment.