DD pro has stopped working on Ps5. Please help

Hi all.

Jumped on the Ps5 after a bit of a break from GT7.

Pressing the PS button on wheel base - Nothing happens.

Yes - It is in Playstation mode

Diagnoses I have done so far

  • Plugged wheel into PC to test buttons (They all all being recognized and working in the fanatec software buttons module tab)
  • Tested wheel on PC with BeamNG. Is all 100% working fine
  • Alternated both rear USB plugs on back of Ps5
  • Updated Firmware of wheel
  • Hard reset of wheel (Switched off, unplugged and replugged)
  • Reset Ps5
  • Alternated start up progress of Ps5, with and without wheel base connected as Ps5 starts?
  • Alternated mode of wheel base (Typically in blue) tried both purple and yellow.
  • Tested connections on back of Ps5


  • Tae YooTae Yoo Member

    I think you've done good series of trials. Maybe few more questions or trials...

    • I'm assuming you're using GT DD Pro wheel? and the wheel doesn't work in GT7 only, works everywhere else?. I would think if you're not seeing the wheel in more than 1 place, would venture to guess a wheel pin issue. If only seeing this issue in GT7, maybe clear Network cache (I doubt it but only thing I can think of without having you to reinstall the game)
    • Do you get Fanatec symbol and FW versions on the wheel when you boot up your DD Pro? lights on the rev meter? I've had better luck avoiding FFB nuances when I boot up my DD Pro After PS5 user login screen is active
    • I would try: 1) power down and unplug everything for ~2min (PS5, DD Pro & power brick), 2) power on PS5, use a controller to log-in, 3) power on DD Pro in main PS5 screen, 4) check to see if DD Pro is detected in PS5 main screen, 5) if wheel is detected in PS5, then go to GT7 to see if wheel is recognized. hopefully it may help narrow the issue down. good luck

  • ** Problem solved **

    The solution : While connected to PS5, turning off the wheel, then turning back on, waiting for the auto calibration to complete and hitting the PS button within the 1-3 seconds of the LED screen coming on to show steering angle. Now it works every time without having to reset.

    Odd thing to happen but nevertheless it's working as always now.

  • Tae YooTae Yoo Member

    Glad to hear. I've not heard of that workaround (PS button within 1-3secs) but good to know. Thanks.

Sign In or Register to comment.