CSL elite v2 loadcell broken

Gday guys, I’ve recently purchased the csl elite v2 pedals (2 weeks old) and my loadcell started to play up, would apply brakes when I wasn’t braking and then not work while I’m trying to apply them, played around with the in game settings and can’t figure it out, tried to update on the pc and it’s got the latest update, reset them also on the pc, I then changed the spring and rubber stoppers out and done nothing, I play on ps5 so I checked the controller and its positioned so it won’t effect the brakes being applied, at this point I don’t know what to do, can you buy the v2 loadcell pedal on its own? I’ve tried for 4 days to get these to work and I’m over it, any help would be great


  • Sounds very similar to the problem I have, using the pedals on PC for about two months. Currently waiting for a reply to my support ticket. I suspect that the load cell is simply broken. It started with the input signal not returning all the way to 0% when releasing the brake pedal. Pressing the pedal repeatedly, the minimum input slowly got bigger and bigger until it was stuck at 100%. At first, it could be reset by re-calibrating in the Fanatec Control Panel. But that didn't fix the actual problem, pressing and releasing the pedal still resulted in the minimum input slowly climbing higher and higher with every repetition. I tried disconnecting and reconnecting all cables, running it via wheelbase or directly to PC via USB, reinstalling drivers, checking firmware. Nothing helped. Eventually the input signal disappeared completely, so now it is stuck at 0%. Makes no difference how hard the pedal is pressed or what brake force setting is used. The pedal seem to be simply dead.

  • My brake load cell is now performing poorly. Each lap provides a different strength output when pressed the same amount.

    Sometimes I need to push extremely hard barely stopping and other times on the same lap so softly as to not lock the brakes.

    My accelerator has a bunch of noise of about 18% which flutters + and - the application.

    I am using USB direct to PC. I need to know what the fix is please.

    I have the csl elite v2 inverted pedal set.


  • Latest firmware and software installed.

    I would say that my loadcell is faulty as it is outputting various numbers.

    I would be happy to buy a new loadcell if it is declared faulty, otherwise the pedals go in the bin because I can no longer reply on them.

    In iRacing my unpredictable brake outputs have lost me 1.5 safety rating points,, so much so that I am about to loose my A license.

    Please help.

Sign In or Register to comment.