Fanatec CSP V3 - Are my pedals dead?

Dear Community, Fanatec Tech Support Team, dear All,

Knowing that the proper procedure should be contact directly Fanatec via RMA Ticket Support channel (which i did already on April 29th 2024 w/out answer so far) I would like to ask your help into the following topic.

I have a BF2023 batch CSP V3 that was connected to a DD2 (with proper RJ12 DD2 cable) since day 1. Everything was running smoothly for (I would say) approx 2months. Although it happened that from time to time, the pedals became disconnected (no input at all) during races, and I would be fixing it with DD2 restarting. When I got tired of it, I just didn't care so much about the problem and changed to USB->PC connection (with RJ12 unplugged).

It happened that during 2/3 months it was ok, until the April 29th. I was racing on April 28th late night, everything OK! Shut Off full setup! and on April 29th (Monday morning -> Holiday actually for myself) I turned on the full setup and no CSP V3 recognized at all. It looked liked they bricked, which is kind of weird and that is not the case (I will explain in a few moments). I have started to work on trying to find a solution, until I had to open the RMA ticket.

Besides the above, I can share some notes/ideas/trying find a solution:

. Noted that after a while without "energy" I am able to have the CSP V3 connected for about 30sec to PC until it disconnects.

  1. tried different cables (both RJ12 from CSP V3 kit, and generic aftermarket USB cable) -> the issue remains the same
  2. tried uninstalling the current driver v455 to v457 or V452 -> did not solved the CSP V3 issues (either via RJ12 or USB)
  3. in order to trace any sort of short-circuit, I have unplugged all the connections (Load Cell + Hall Sensors + Rumbles) -> the issue remains the same

So in fact I have tried all the above with all the variables possible and didn't solved my issue. I have searched everywhere in the net (google xD) and find zero problem/solution after all, and I do trust in Fanatec reliability afterall.

This is my 2nd CSP V3 set, the first one I sold after 4 years of usage and ZERO hardware problems, only the original foams that got "squeezed" -> solved with BPK rubbers upgrade.

My conclusion is that it can be related with a "broken" PCB, maybe.

Did anyone experienced something like this?

Thank you everyone in advance.


  • @Belma Nadarevic can you help?

  • i would like to have a bigger post but it seems it needs to be approved ... :/ .. but there you go below less details.

    On May 10th i got my first and only feedback from Customer Service. Replied on 13th, and no news so far. All tests (connections, cables, drivers,etc) were performed as per request, although as it can be seen above I did a lot of them already and no chance it worked.

    I will share with you a video where I can have the pedals communicating for about 1min and something and then it just turns off. after that nothing happens. it seems it "overheats" something.

  • Meanwhile i have received a new email from Fanatec (on June 3rd), apologizing for the delay and with a solution, new PCBA. Waiting for dispatch now.

    special reference for the below quote:

    "Thank you for getting back and please excuse the late response.

    We know a response to your inquiry is overdue and for that we'd sincerely like to apologize. We want to inform you that due to an unusually high workload, our response time is longer than usual. We appreciate your patience and assure you that we are working diligently to address all inquiries."

    We know, still it's our items. Apologies accepted.

Sign In or Register to comment.