CSL Elite Pedals V2 not working


Got my CSL DD READY2RACE MCLAREN ELITE BUNDLE (8 NM) FOR XBOX & PC about a week ago. When first installing the setup I didnt got my pedals to work. Manage to connect them to an old PC and updated the firmware. Still not working. Later the same day I tried to switch up the cable that goes from the CSL DD to the pedals and suddenly the pedals was working.

The next day I changed the power outlet for the csl dd and the pedals stopped working again.

When it is connected to the pc, I can see that the gas and brake register input. But when I test in the game f1 -23 nothing happens. Tried changing the cord completely to a new one. Tried reinstalling f1-23. Tried repairing the drivers. Nothing is helping. What else can I try?


  • Dude I am having an issue with the wheel on xbox. The rotation on it is like 45degrees. Nothing happens when adjust in f1 24. Does this sound like a firmware issue? I am trying to update the firmware through my laptop but am also having issues with that.

  • MadDog-ICMadDog-IC Member
    edited June 6

    @Johan Borjesson

    Assuming your doing this all on a PC with F1 23 and not the Xbox:

    1) If you have multiple joystick, Wheel base, Game pads etc in "Windows -> Printers and Devices" make sure your "Fanatec Wheel" is Device 0 (Some games can't use any device on any other device number such as 1,2,3) , make sure it's given priority as the default one to use under the advanced tab of any of the game devices.

    2) If running F1 23 from steam disable: "Steam Input for that game or all games" (Steam inputs remapping functions has be known to interfere with Fanatec's drivers/hardware).

    3) In Fanatec Config panel, check for a "Combined pedals" option under the pedals section and this should usually be turned off.

  • MadDog-ICMadDog-IC Member


    I am not familiar with F1 24, but it may not be able to:

    1) Auto detect the wheels "Degrees of Rotation from the Fanatec Config correctly when, Sen=Auto, so set it to say Sen=1080 or 360 would be more realistic and then set the same in the game config of 360 degrees or the Sensititivity to approx 30% of 1080 = 360 degrees (If the game has a soft lock option, you would need to calibrate your wheel).

    2) You haven't calibrated your wheel in game to match the games "Degrees of Rotation" with a soft lock that varies based on each cars actual steering wheel rotation.

  • Hi,

    Thanks for the response.

    I seem to have fixed the issue by removing the cable from the pedals to the Xbox. Now I am only using the cable from the pedals to the CSL DD.

    Might sound weird but now it has worked every time :)


Sign In or Register to comment.