CSL pedals brake not working

Cory70jCory70j Member

Just received my CSL pedals today aswell as the USB adapter got everything plugged in aswell as firmware and for some reason only my throttle worked I’ve tried rebooting my computer trying different usb ports not sure what’s going on I also tried plugging the brake into the clutch port to see if any input appears which it did however it was a jump 80-100% at all times and my actual input to the pedal changed it none


  • Allan LehtlaAllan Lehtla Member
    edited June 19

    you connected pedals only to usb right? and not to the base. because they not allowed connect both at same time

    in they video they add that inside ss usb port, dunno if that makes any difference but by default that have more power


  • Cory70jCory70j Member

    Yea I don’t have a Fanatec base just the USB adapter to pc

  • Do you have load cell?

  • I have am issue where the pedals stop working and

    I have to plug out the RJ12 and plug it in again ( from DD plus to pedals base plate)

    Is there any permanent fix to it ? using only RJ12 via DD plus for PS5

Sign In or Register to comment.