CSW 2.5 - Red light not working

I remember I fixed this problem once, but I don't remember how...image


  • Joseph GossenJoseph Gossen Member, Moderator
    Hi Samuele,

    Can you provide more information? What is happening with the red light? Does the wheel function correctly? The more details the better.

  • Samuele DodiSamuele Dodi Member
    edited May 2019
    The wheel works fine, it's only a not working light in the ring around start button.
    Blue lights and green lights are 100% working, red lights aren't, only 3 out of 4.
    See the attached photo in OP (EDIT: ok, you couldn't see it before now).
  • edited June 2019
    I've seen this twice. One time, upgrading the firmware solved the issue. The other time, only replacing the power button solved it.
  • Well, this is my second time and I already tried upgrading the firmware... So I should replace the power button, I guess.
  • It works again! I did nothing, anyway.

  • Maybe try and see if the cable connecting to the power button is loose. That would mean opening up the base, of course, so if you still have warranty you should discuss this with Fanatec Support first.
  • My base is only 4 months old, opening is not an option, at the moment. :)
Sign In or Register to comment.