Steering wheel acting up [video]

since I've changed the USB port from front to back of my PC, the wheel started acting up. It's like it thinks that it's upside down, I don't know, just watch the video:

Additionally, the wheel doesn't respond well to profile changes. For example, if I set a profile to 90°, I can rotate the wheel 270° to both sides. Also the PC software shows me wrong degrees when turning the wheel. At the full spectrum of 900°, the software only shows 71° to both sides - it also translates like that into every game. 140° and below is the only setting where the slider goes all the way from -450° to 450°.

I seriously don't know what's wrong. I've tried to reinstall the software multiple times, I've also flashed the firmware, it is now on version 627 (ClubSport Base V2) - no idea what it was on before. I've also looked all around the internet but I couldn't find one single thing that I could try. Maybe you guys have some ideas. I'm on Windows 7 x64, if that's relevant.

I was about to drive a few rounds on my free weekend. I guess that's it for now. Thanks Fanatec.


  • Edit:
    After upgrading to the newer firmware, the wheel behaviour looks like this:

    It may look like FFB is broken but it isn't, it drives just fine apart from the wrong steering.
  • Edit#2:

    I thought that I might be able to drive when I set the wheel sensitivity in the game (doesn't matter which game), but I was wrong. It certainly works, I can turn left and right and it translates it properly into the game. BUT. The wheel keeps pushing to the right side as soon as I steer a bit to the right over the 0 point. Steering to the left is fine though.

    What a weird behaviour. I've paid hundreds of €€€ to play for 2 days and then wait for support for the rest of the time. I bet I'll have to send something back and spend weeks waiting for it to get repaired or replaced. What a blast.
  • Question for you, if you plug it back in where is was originally, I believe you said it was the front, does it work properly?
    If it does it that a USB 2 or USB 3 port?
    What version of USB port are you plugging into at the back?
    I have had wheels behave differently depending if it is USB 2 or 3.
    I only mention this as I have experienced the very hard to move symptom you show in your second video
  • No, doesn't matter what slot it's plugged in, doesn't even matter what PC it's plugged in or if it's plugged in at all.
    Both USB are 3.0, but the one at the back is mounted on the motherboard, the one on the front is plugged on the motherboard with a cable.
    Haven't tried plugging it into USB 2.0 but will try it - I don't expect much though, since as I said, it even acts up when not plugged in at all.

    Additionally, the weird behaviour I've described a post before works both directions, left or right, depending on what direction the wheel is turned when it's turned on. If it's turned 1° to the right, the wheel keeps pushing to the right when playing. When the wheel is turned 1° to the left, it keeps pushing to the left. If it's exactly centered on the 0-point when turned on, the red LED on the start button starts flashing. It's always one direction that's broken, the other direction works just fine.

    So, I can still play as a nascar, if I turn the wheel to the opposite side of the circuit direction at the start. He-he.
Sign In or Register to comment.