Firmware launcher Help !!!!!!

Can anyone help as I have had no redponse from support for this problem now since contacting them. I have installed driver beta 336 and firmware 656 onto fanatec podium hub DD2. I then attach my Formula V2 wheel and it immediately prompts me to update the rim to latest firmware I select okay and the DD2 wheel base shuts down and the wheel Rim just has a fanatec logo on the lcd screen but nothing else happens . The firmware launcher does not start or appear on my desktop. I have uninstalled and reinstalled drivers . I have tried all usb ports I have tried laptop This also occurs when attaching my other rim the Mclaren gt3 My fanatec shifter and the DD2 opened the firmware launcher and firmware installed on both those devices no problem, so im sure its not a wondows 10 issue. Any help appreciated as customer support haven't got back to me.


  • Joseph GossenJoseph Gossen Member, Moderator
    Roll back to driver 335 which is on the DD2 downloads page. Try updating your wheel firmware then.
  • Rolled back to 335 and still the same. The firmware launcher wont launch on desktop the wheel base shuts down and fanatec logo on lcd of wheel rim . What else do you suggest ?
  • Joseph GossenJoseph Gossen Member, Moderator
    Hi Neville,

    If you navigate to ProgramFiles/Fanatec/FanatecWheel/fw/ base update/ Will it launch from there?
  • Yes but then i get a text box prompt instructing me connection failed something about a failed ping and to connect wheel and place base in bootloader mode. Not with PC right now so dont have exact wording. Its strange as this occurs with wheel attached and recognised in wheel properties
  • Joseph GossenJoseph Gossen Member, Moderator
    I would then suggest reaching out to support.
  • If you have a 64 bit system try this. I have had similar problems with other software in the past.

    Delete all Fanatec software from your system and reboot.
    Install the 32 bit version first and reboot.
    Next, install the 64 bit version and reboot.

    This should fix your problems. But again only if you have a 64 bit system.

  • Will give this a try alrhough it previuosly crossed my mind to download the 32 bit version but when i tried it my system wouldnt let me as I have 64bit system so it denied the download . Im into support about this issue and they have requested a video
  • Same problem here. Did you solve it Neville Richards?
  • updated firmware and drivers, now shifter doesn't work, cannot calibrate. Error "ClubSport Wheelbase could not be identified" Windows controller shows all OK. I bring up wheel properties, wheel turns, but no shifter. Unable to find any reference to calibrate this type of wheel and shifter. Everything was working accept button cluster, hence the reason I decided to update firmware per online forum. Made every attempt at uninstalling and reinstalling many referenced drivers. Not able to reach support in a timely matter, not able to find or download previous firmware version. I would like to roll back to previous Firmware, I now have no idea what that was. Just received my equipment yesterday 4/16/20, where can I find it??

    I racing does let me assign shifter buttons however, as soon as I go in I cant not shift vehicle

    CSL Elite Wheel Base V1.1

    Podium Hub QRA

    Podium Wheel Rim Nascar

    ClubSport Button Cluster Pack

    ClubSport Shifter H Pattern

    ClubSport Pedals V3 inverted

    PC driver ver: 336

    WB FW: 656

Sign In or Register to comment.