DD2 no force feedback bug happening on TWO units installed in completely separate systems

This is a strange one. 
I have a DD2 wheel base, and so does a family member in a completely separate location.,. both with the Fanatec Porsche 918 RSR rims. 

They are running on separate rigs, on machines with different specs etc... but both are having the same issue which suddenly appeared two days ago.

When you start up a game, everything is fine. BUT if you exit a game, and load another, there is no force feedback in game. You can steer the car, but there's no resistance there.

Going into the Fanatec software, and clicking on the properties for the DD2, all the other tests (lights, vibration etc) are fine but the FFB test produces nothing at all. 
There always seem to be two instances of the Podium DD2 device in the software, and clicking on the other device to make it active allows for the FFB test on the second device to work.
Loading into a game, it behaves as it should. But If I exit that game, I lose FFB again. And this time both DD2 devices in the software have no FFB when I run the test. 

Strange that it's happening on two completely separate systems... there has to be a relation with either a software update or something else.

Has anyone else experienced the same issue? Anyone have any ideas as to what could be the cause?


  • What driver and firmware versions are both of you using?
  • One is definitely on the latest - because updating and re-flashing the wheelbase it's the first thing I did when I tried to troubleshoot.

    The other one I'm not sure, but it was last updated around 3 weeks ago. I'll check tonight. 
  • What type of USB ports (2.0, 3.0) are the wheels bases plugged into? If 3.0, would you have a 2.0 port that you could switch to and see if that changes the behaviour?
  • Thanks for the suggestions, but I think I’ve figured it out. There seems to be a conflict with Simhub. After I exit a game, I’ll have no FFB until I close Simhub and re-open it. I repeated this five times tonight, and closing and re-opening Sim-hub worked every time. Very strange.
  • OK, thanks for the additional info. I'll make sure the devs know, maybe it's something to improve in the DD driver/firmware.
  • edited August 2019
    Did you get any windows updates??? I recently got the windows 1903 update and the FFB was Off...I tried to repair the Driver it didnt work... I ended up uninstalling and reinstalling the driver and all works as it should Now.
  • Correction: it was irffb.exe that was causing the issue (iracing force feedback tool). With irffb closed, everything is fine. Confirmed on both systems. I’m not aure about a windows update, I don’t recall getting one but it’s possible. I might try re-installing the driver at some at some stage.
  • This isnt a fanatec thing.. but windows i believe. Also happens with my Thrustmaster TSPC base.

    For example I have an Odyssey+ headset and if i load iracing BEFORE i load steamVR i wont have any ffb when i enter the game., even though everything else is fine. To get it working I have to load steamvr and crew chief BEFORE entering iracing and then its fine. - Its a known bug for windows mixed reality headsets... but your issues sounds similar if your using third party apps like simhub - its like your ffb is being taken over by the last loaded app.

    What doesnt help is that some games are different from others (Assetto corsa is actually the opposite.. it prefers if i load into a race without steamvr open) 

    Once you get used to what you need to do in each sim its not an issue, just an annoyance.. but to begin with i spent AGES trying to figure it out.

    I suspect it will be exactly the same with my podium F1 which I get next week. 
Sign In or Register to comment.