Fanatec Beta Driver V344 for CSL, CSW and Podium Bases (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator
edited August 2019 in Beta drivers
Hello Everybody,

Changelog of V344:

A. Driver 
1. Fixed issue that McLaren GT3 v1.0 able to select "ENC" as MPS Mode.
2. Added Tuning Menu settings page to the Driver UI.
3. Added functionality for upcoming products
4. Firmwares included:
   - CSW V1 Base : CSW_Base_V662_rev1681_app     (NEW)     
   - CSW V2 Base : CSW_V2_Base_V662_rev1681_app    (NEW)
   - CSW V2.5 Base : CSW_V2_5_Base_V662_rev1681_app   (NEW) 
   - CSL E Base  : CSL_E_Base_V662_rev1681_app    (NEW)
   - CSL E Base PS4 : CSL_E_PS4_Base_V662_rev1681_app   (NEW)
   - DD Base  : PDW_DD_Base_V662_rev1681_app    (NEW) 
   - EBLDC   : CSLEWBPS4_CSWBV2.5_EBLDC_V22_rev335_app 
   - EBLDC DD10  : PWBDD1_EBLDC_V30_rev356_app    
   - EBLDC DD20  : PWBDD2_EBLDC_V30_rev356_app    
   - RMCL  : RMcL_V30_rev38_app       
   - RFORMV2  : RFORMv2_V28_rev113_app
   - PHub   : SW_P_Hub_V1_rev113_app
   - WQR   : PWBDD_WQR_V6_rev65_app

B. Firmwares:
- Podium DD: Reworked Power Button behaviour
   FFB dis-/enabeled by short press <1sec
   >1 second press switches base off (with message on display)
- Added functionality for upcoming products

Known Issues:
  • Sorry the "notchy" issue of CSW V2.5 and CSL E PS4 which some testers experienced is still under investigation and couldn't get fixed yet. I've attached motor firmware V20 which has less coil whine than V18 and less notching than V22 according to some testers. 
If you report a driver or firmware issue, please make cross checks:
0. Update driver and FW separately to isolate an issue. Most likely it will be driver OR firmware.
1. Which driver OR firmware does show the issue
2. Which driver OR firmware does not show the issue
3. Check if you can reproduce the issue again if you go back to the version which seems to have cause the issue
4. Post the answers gathered from the questions above + a short description of the issue including the following information:

Wheel Base Model (product ID): ....
Steering Wheel Model (product ID): ....
Driver Version: ....
Base FW Version: ....
Wheel FW Version: ....

Thank you very much!

We hope for your positive feedback! 
«13

Comments

  • Rinus HuismanRinus Huisman Member
    edited August 2019
    Gonna test it. What are your thoughts on my superlong post in the previous topic? 

    Btw. The tuning menu is the best thing since sliced bread. Perhaps lets us name the Sets. 
    Edit: Max sens is btw 910 in turning menu. Is there a reason for it? I assume that's meant to be auto. 
  • On PC Windows 10 Pro 64bit.
    Coming from Driver v328...Removed old driver rebooted, installed v344 and installed new FW......Was showing this issue after 1st install so, did an uninstall of new driver, rebooted installed again v344 and this issue still remains. see picture.

     
  • edited August 2019
    I had same Issue @4k Resolution... you have to Set Screen Resolution to 1080p and all reads correctly...

    My Question is can these settings be used??? Sooo far I can't push the Apply Button to save the settings to the wheel.

    Windows 10/64bit
    DD2 w/Universal Hub + APM
    Dr 344
    FW 662
    Mtr FW 30

    Bugs Noticed So Far
    PC New Properties Tuning Menu page after you set your settings the apply button can Not be pressed... settings seem to stay in wheel any way But when I set SHO on the wheel to 100  the New Tuning Menu in the properties page stays at 80....



  • I had same Issue @4k Resolution... you have to Set Screen Resolution to 1080p and all reads correctly...

    My Question is can these settings be used??? Sooo far I can't push the Apply Button to save the settings to the wheel.
    Set my 4K monitor to 1080p and it's still the same ... I can't believe I used to play @1080p a couple of years ago Yuk!!! ;)
  • edited August 2019
    No bug, but some suggestions:
    • it would be nice if the tuning menu settings could be copied, so I can make SET 1 for example and then copy the settings to SET 2
    • there is no way to type in the value directly. You have to use the slider or the "<" and ">" button on the UI
    • it's a little bit confusing that some settings are needed to be set to over 100 to be turned off and some settings are needed to set to 0 (but that's also inside the tuning menu of the wheel base)
    • on some settings it shows 0 as off and on some settings it shows OFF (but that's also inside the tuning menu of the wheel base)

    So nothing dramatic, but maybe something you guys can think about ;)

    Edit: The sensitivity slider in the UI is missing here, too.

    I had same Issue @4k Resolution... you have to Set Screen Resolution to 1080p and all reads correctly...

    My Question is can these settings be used??? Sooo far I can't push the Apply Button to save the settings to the wheel.
    The settings are active in your wheel as soon as you change it in the driver UI. No need to press "Apply".
    You can check it, if you go into the tuning menu in your wheel and then change it in the UI. You see it changing directly also in your wheel.

    And btw. no problem here at 3440x1440
  • edited August 2019
    Getting a driver Freeze *sometimes* when I click the new Tuning Menu Tab and then back to the Function Test tab.
    Windows Shell Common DLL isnt responding anymore in this case and the whole driver windows freezes and needs to be restartet, happened several times already. 
    Happens with all kind of wheels (UHX, Formula eSport, Formula v2, McLaren).
  • I had same Issue @4k Resolution... you have to Set Screen Resolution to 1080p and all reads correctly...

    My Question is can these settings be used??? Sooo far I can't push the Apply Button to save the settings to the wheel.
    The settings are active in your wheel as soon as you change it in the driver UI. No need to press "Apply".
    You can check it, if you go into the tuning menu in your wheel and then change it in the UI. You see it changing directly also in your wheel.

    And btw. no problem here at 3440x1440
    I'm using Full 4k 3840 x 2160

    also the SHO will Not set above 80 in the New wheel properties tuning screen...Even if I set it on wheel to 100% the New tuning screen in the wheel properties pages will Not go above 80.
  • I had same Issue @4k Resolution... you have to Set Screen Resolution to 1080p and all reads correctly...

    My Question is can these settings be used??? Sooo far I can't push the Apply Button to save the settings to the wheel.
    The settings are active in your wheel as soon as you change it in the driver UI. No need to press "Apply".
    You can check it, if you go into the tuning menu in your wheel and then change it in the UI. You see it changing directly also in your wheel.

    And btw. no problem here at 3440x1440
    I'm using Full 4k 3840 x 2160

    also the SHO will Not set above 80 in the New wheel properties tuning screen...Even if I set it on wheel to 100% the New tuning screen in the wheel properties pages will Not go above 80.
    confirm regarding SHO not going above 80. And when lowering in the driver Tuning Menu then its jumping from 80% to 40& and then to OFF. This setting definetely is broken.
  • Like the addition of the tuning menu and the ? explanations.  

    Would like to have seen the two properties of the DD temperature and fan speed.

    Like the one second off.

    Nice forward progress.
  • edited August 2019
    Windows 10/64bit
    DD2 w/Universal Hub + APM
    Dr 344
    FW 662
    Mtr FW 30

    Can the Driver properties page be resized so it Displays properly in full 4k 3840 x 2160???

    I reinstalled DR 334 to My PC and wheel FW Seems Good All is working as it should... Including the New Cut FFB and Power On and Off timing.
  • Windows 10/64bit
    DD2 w/Universal Hub + APM
    Dr 344
    FW 662
    Mtr FW 30

    Can the Driver properties page be resized so it Displays properly in full 4k 3840 x 2160???


    Agree, yes please ;)
  • I think the missing sens setting is intended, cause we can change it now in the new tuning tab. 
  • Charlie YowCharlie Yow Member
    edited August 2019
    Fanatec control panel would not launch, so I decided to simply update to the latest drivers.   Then I got the following error window"

    "There is a problem setting up the wheel control panel. Please reconnect the device and try again"

    As of now I have uninstalled, reinstalled the 355 drivers multiple of times.
    Updated Motherboard USB Hub drivers.
    Tried several, if not all of my USB ports after each RESTART.

    Still get the message above and no Wheel control panel to control the settings.....???
  • Tuning Tab is only for DD's?
    Have a CSL-E V1.1 and no tuning tab.
  • edited August 2019
    Unfortunately, the driver still freeze when I try to start Clubsport universal hub. CSL Elite Wheelbase V1.1 Wheel Base: 662 Motor: 22
  • So good having the 5 tuning menus in the driver page now :)
    Next thing to make it perfect would be to let us name them so that e can see the game name on the wheel to know which one other than just by number ;)
  • Marcel PfisterMarcel Pfister Member, Administrator
    Gonna test it. What are your thoughts on my superlong post in the previous topic? 

    Btw. The tuning menu is the best thing since sliced bread. Perhaps lets us name the Sets. 
    Edit: Max sens is btw 910 in turning menu. Is there a reason for it? I assume that's meant to be auto. 
    Please always report what Hardware and Firmware you are using, I guess it's the CS WB V2.5 in your case. I've checked and can confirm that the SEN slider is buggy when using a CSW V2.5.

    No it will not be possible to set names there, but with the upcoming PC software "FanaLab" you will be able to save multiple setups per game with different names and you can select one to be automatically loaded on game start. 


    On PC Windows 10 Pro 64bit.
    Coming from Driver v328...Removed old driver rebooted, installed v344 and installed new FW......Was showing this issue after 1st install so, did an uninstall of new driver, rebooted installed again v344 and this issue still remains. see picture.

     
    Did you do only restarts before installing 344 or also afterwards? Please also mention what wheel base you are using, is that a DD in V2.5 COMP mode? Just tried and for me it looks correct. Wheel SEN is missing on purpose because it's now part of the Tuning Menu page. Whats the resolution of your screen?


    I had same Issue @4k Resolution... you have to Set Screen Resolution to 1080p and all reads correctly...

    My Question is can these settings be used??? Sooo far I can't push the Apply Button to save the settings to the wheel.

    Windows 10/64bit
    DD2 w/Universal Hub + APM
    Dr 344
    FW 662
    Mtr FW 30

    Bugs Noticed So Far
    PC New Properties Tuning Menu page after you set your settings the apply button can Not be pressed... settings seem to stay in wheel any way But when I set SHO on the wheel to 100  the New Tuning Menu in the properties page stays at 80....


    The settings should change in real time when you move the slider, go into one setting on your wheel base so you see the value and then change to slider, then you should see the change immediately. Also the other way around when you change something on the base, the slider in the driver should move at the same time. 

    I tried the thing with SHO but for me the slider doesn't get blocked at 80, is it still happening on your side, did you do a restart?
  • Marcel PfisterMarcel Pfister Member, Administrator
    Regarding the bugs of stuff being clustered around for some in 4k, is it dependend on zoom levels you use inside of windows? Please try to experiment around a bit with resolutions and zooms and so on. 
  • Marcel PfisterMarcel Pfister Member, Administrator
    edited August 2019
    I think the missing sens setting is intended, cause we can change it now in the new tuning tab. 
    100pts for you ;-)
    Fanatec control panel would not launch, so I decided to simply update to the latest drivers.   Then I got the following error window"

    "There is a problem setting up the wheel control panel. Please reconnect the device and try again"

    As of now I have uninstalled, reinstalled the 355 drivers multiple of times.
    Updated Motherboard USB Hub drivers.
    Tried several, if not all of my USB ports after each RESTART.

    Still get the message above and no Wheel control panel to control the settings.....???
    Can you try either on older driver like 335 or the repair function of 344?
    If that doesn't help you might have to manually go to the device manager in windows and uninstall the USB drivers saved. Maurice probably knows more about this.
    Tuning Tab is only for DD's?
    Have a CSL-E V1.1 and no tuning tab.
    Tuning Tab only works with CSL E WB + (PS4), CS WB V2.5, P DDs. Reason is only they are shown as two devices and can make use of the communication of multiple devices which is needed for those complex commands between driver and WB besides all the other stuff that is already happening.  Sorry sadly older bases and the new CSL E 1.1 can't be supported with that feature. 


  • Had a recurrence of the problem where the wheel will not get to the OK torque key state.  It would hang up and the Properties page would not open.  It would not respond to power on/off only kill switch.  However when powered back up it would again not get to the OK torque key state.

    Window 10 Pro 64
    DD!
    F1 2019
    V3


  • @ Marcel Pfister
    Sorry, I restart my PC always after an install, and also after an uninstall, it's not always necessary in Windows 10, but testing beta drivers it's almost a requirement. :) CSW base v2.5, 43 inch 4K monitor 3840x2160 native resolution   
  • edited August 2019
    Marcel Pfister   Hello I have figured out the Bug with the SHO getting Locked to 80... it happens when you check the Map Sequential shifter to paddles Box...When this box is checked the SHO setting Automatically sets its self at 80 and will Not set at 100...also the when you try to adjust it the Numbers jump around erratically and it changes your wheel FFB save slots....See Video

    Edit: I also have the Podium APM module on the Xbox universal Hub and it seems that with the New Driver that the Clutch Paddle Travel Range issue has been fixed...From what i see they reach 100% at the end of their travel range.

    Windows 10/64bit
    DD2 w/Universal Hub + APM
    Dr 344
    FW 662
    Mtr FW 30



  • Regarding the bugs of stuff being clustered around for some in 4k, is it dependend on zoom levels you use inside of windows? Please try to experiment around a bit with resolutions and zooms and so on. 
    I tried all the DPI/Text Size settings and Nothing Fixes the Scrambled Text at Full 4k resolution 3840× 2160... The Only thing that works is If I reduce the desk top resolution to 1920×1080... Please Look into this... I'm lazy and don't want to change My desk top resolution every time I need to use the wheel properties page....Take Note the Properties page has always been this way with all Drivers @4k resolution... Its just Never been a issue because there were No settings in there to adjust.
  • I guess I'm lazy too :) I know not everyone runs in full 4K but it must be getting popular though surely!
  • Well well well...

    image
  • Well well well...

    image
    set your Monitor to 1920 x 1080 and it will unscramble.
  • edited August 2019
    I guess I'm lazy too :) I know not everyone runs in full 4K but it must be getting popular though surely!
    Next year they will be coming out with Monitors/TV's that have HDMI 2.1!!! This will support Full 4k @120FPS!!! Save your $$$ Now they wont be cheap!!! Yup I plan to have 1   :D  Full 4k at 120FPS will be Insane  \:D/
  • Thanks for the advice but no... I'll not change resolution to use a Fanatec beta driver.
  • Ben MansillBen Mansill Member
    edited August 2019
    Typos on the software... 

    Fanatec, it's:

    BRAKE not BREAK
    THROTTLE not THROTLLE

  • Marcel PfisterMarcel Pfister Member, Administrator
    Marcel Pfister   Hello I have figured out the Bug with the SHO getting Locked to 80... it happens when you check the Map Sequential shifter to paddles Box...When this box is checked the SHO setting Automatically sets its self at 80 and will Not set at 100...also the when you try to adjust it the Numbers jump around erratically and it changes your wheel FFB save slots....See Video

    Edit: I also have the Podium APM module on the Xbox universal Hub and it seems that with the New Driver that the Clutch Paddle Travel Range issue has been fixed...From what i see they reach 100% at the end of their travel range.

    Windows 10/64bit
    DD2 w/Universal Hub + APM
    Dr 344
    FW 662
    Mtr FW 30



    Thanks a lot for finding this connection, this will help solving it for sure.
This discussion has been closed.