Struggling so hard with Control Panel and firmware manager


I recently received my Fanateec order (DD2 base, F1 and WRC wheels, inverted V3 pedals, gear shift lever, and handbrake). After hours of testing and research, I'm still having a major issue with the Fanatec Control Panel and the Firmware Manager.

Firstly I connected everything and installed the latest driver version (452) and attempted to update the various firmwares. Like many people I encountered a problem with the motor firmware version not being compatible with the base version. I followed the described procedure, namely uninstalling the driver, installing version 336, then reinstalling the latest driver and flashing my device again. I tried for hours in every possible way but could never update my motor to the latest version (I could only get motor version 30.0). I did all this with my gaming PC and after hours of struggle, I decided to try connecting my base to my laptop. Magically I managed to update everything (driver version installed on the laptop: 452), and the firmware updater indicates that everything is up to date on my laptop (which doesn't even seem true, as the motor version I currently have is 3.0.0 whereas apparently, there is a 3.0.2 version now). I then reconnected my base to my gaming PC and the control panel indicates that I need to update the firmware. I try to do it but it's impossible.

In fact from the beginning I can't update my equipment to the latest version with my gaming PC. If I start the updates with the green button, nothing happens, the program freezes and crashes. If I try the updates by pressing the button on my base for 8 seconds the update seems to go through but in the end, the latest versions are not installed.

I must also mention that every time I open the control panel, if I close it, I can't reopen it without killing the process in the task manager. Another thing : when I switch to advanced mode in the control panel it doesn't work, it automatically switches back to standard mode and dont displays any advanced setting.

I should clarify one thing : everything works, my base, my wheels, pedals, etc., I was able to test them in-game and they work. But there's really a problem between the control panel, the firmware manager and my gaming PC. I've tried for over 10 hours to do everything and in every way, I don't understand what's not working with my PC. Here's a short list of what I've done:

  • Deleted all Fanatec devices from the device manager.
  • Deleted the drivers and reinstalled them (I also tried version 451).
  • Connected my base to different USB ports.
  • I've restarted my PC and my base countless times, in every way, deleted everything and reinstalled everything several times.

I can't even describe everything I've tried otherwise my message would be too long. With my laptop, the firmware updater apparently works fine, but with my gaming PC, it's a mess. So I'm reaching out to you, I need help because I really don't know what else to do. Should I possibly update the BIOS of my motherboard ? What makes my PC hate the control panel so much? If someone can help me I would be extremely grateful. I can provide logs if necessary, or any other information.

Thank you.


  • edited November 2023

    You need to uninstall driver 452.

    Then install driver 336.

    Then press and hold the Power Button of the Base while the base is off to start the Base directly into bootloader version.

    Just click "Flash Firmware" so an old Base FW v656 gets flashed to the base again which can communicate again with the old Motor FW v30.

    Only then uninstall driver 336 and reinstall driver 452 (or better 451) and then start the Firmware Manager to run the automatic update process by clicking on the green update button. It should start with the Motor Update first, but apparently, for an unknown strange reason, sometimes the updater starts with the base FW update which leads to your issue. 452 had a potential fix for this included but it seems the fix does not work. :(

    Could you also please use the "Collect Logs" feature of the Driver and upload them here so I can forward them to the dev for further investigation?

  • Hi Maurice,

    I've already done this more than a dozen times from my gaming PC but it didn't work. In fact, I can install the Base FW v656 without any problem, but then when I install driver 452 (or 451), the motor doesn't update correctly. However, it worked the first time when I did it with my other laptop, I have the motor version v. 3.0.0 installed. But now it's impossible to install v. 3.0.2 from my gaming PC. I think it's really related to my gaming PC, but what could be causing this? I'll post my logs later in the day to see if it can help.

    This really seems to be a problem between my PC and the control panel, considering that I also have several bugs, especially the FW updater which crashes every time I click the green button. And when I close the control panel, it's impossible to reopen it without killing the process first.

    Thank you.

  • edited November 2023

    3.0.0 would be the correct Motor Firmware.

    The full version is but the last digit is not shown in the Display of the wheel during boot so when 3.0.0 is shown then it is correct.

    Driver and Firmware Manager however would need to . show the full version (Note: 3.0.2 would be wrong).

    But yes, somehow your PC seems to have massive issues with the Control Panel for whatever reason.

    Which Windows Version do you have installed?

  • Thank you.

    Today I investigated a bit more, and here are the results. As I've already mentioned, I updated all the firmware from my laptop and everything worked very well. But when I then connect my base to my PC, nothing seems to work properly. (the attempt to update by pressing the button for 8 seconds doesn't change anything). Below are 2 screenshots: the first is the control panel on my laptop and the second on my gaming PC.

    Everything works fine on the laptop apparently, it recognizes the correct versions of the installed FW, the advanced mode of the tuning menu works well. And if I switch and connect the base to my PC, you can see in my screenshot that nothing is right. The control panel sees the wheel base version at 768 ?? And the wireless QR at 0? And the tuning window appears like this?

    Moreover, when I connect the base to my PC, I don't get the Windows notification telling me that I just connected the device, yet I have it on the laptop.

    I should mention that I don't have anything else connected via USB on my PC.

    The PC is very clean and works very well with all devices, I don't know if an installed program or something could be causing the problem. It's very annoying.

    I am attaching my last logs generated after my attempt to update from my PC.

  • this is some weird shit happens, because if you already update your firmware, it should not show update again at other pc

  • Allan LehtlaAllan Lehtla Member
    edited November 2023

    by the way you image shows driver 451 not a 452.

    you probably should stay away at driver 451 first place

  • Ehm no, 452 is actually worse than 451 and should only be used if you have a BMR, otherwise you should stay on 451 or use todays upcoming 453.

  • then probably use instead the 450, i know there been not talk about 451 but there was actually some issues in sdk at 451

    that worse or better feeling may come from also game self if lasy game developers not updated they sdk

  • edited November 2023

    Ehm no, 450 is worse than 451... Much worse actually. 451 was a super stable driver for the last 10 months.

    Best is to use the just released 453.

  • Yes, I know my image shows driver 451 because that's the one I tried last. But regardless, I've tried with 450, 451, 452, always the same result : ok on the laptop but not on the PC. Unless someone has another solution, I'm going to try updating my BIOS as well as all the drivers for my motherboard, and as a last resort I think I will reinstall my OS. It's very frustrating. Shit is very weird.

  • So, the BIOS update and the new driver 453 didn't change anything. I loose hope...

  • I reinstalled my OS, and now everything is working well. I will gradually reinstall all the programs I had to see if one of them is the cause of the bug, possibly to help others who might encounter the same problem as me. For now, it remains a mystery. Thank you for your help.

Sign In or Register to comment.