Fanatec Driver 455 Release for CSL, CS and Podium (all wheels)

Marcel PfisterMarcel Pfister Member, Administrator

How to report issues:

If you report a driver or firmware issue, please make cross checks:

  1. Update driver and FW separately to isolate an issue and find out if caused by driver OR firmware.
  2. Which driver OR firmware shows the issue
  3. Which driver OR firmware does not show the issue
  4. Check if you can reproduce the issue again if you go back to the version which seems to have caused the issue
  5. Check if the issue is related to specific settings of for example the tuning menu. Is it happening more or less with a specific setting raised or lowered?
  6. Post the answers gathered from the questions above + a short description of the issue including the following info:
  • Wheel Base Model (product ID): ...
  • Steering Wheel Model (product ID): ....
  • Driver Version: ....
  • Base FW Version: ....
  • Motor FW Version: ....
  • Wheel FW Version: ....
  • FanaLab Version: ....
  • Tuning Menu settings
  • Driver/FanaLab installed on C: drive or else?
  • With driver related issues collect log files and zip them from C:\Users\Public\Fanatec Logs

Changelog of driver 455 (since 454)

Firmware versions included

  • Podium DD1 / DD2 Base: (NEW)
  • Podium DD1 / DD2 Motor: 
  • Podium DD1 / DD2 WQR: 7
  • ClubSport DD(+) Base: (NEW)
  • ClubSport DD(+) WQR:
  • CSL DD / GT DD PRO Base: (NEW)
  • CSL DD / GT DD PRO Motor:
  • CSW V1 Base: 693
  • CSW V2 Base: 693
  • CSW V2.5 Base: 693
  • CSL Elite Base: 693
  • CSL Elite Base PS4: 693
  • CSL / CSW Motor: 22
  • Podium BMW M4 GT3: 9
  • Podium Hub: 6
  • • Podium BME: 24    
  • Podium BMR:  
  • CS SW Formula V2(X), V2.5(X): 47
  • CS SW RS: 4 
  • CS SW BMW V2: 3 
  • CS SW F1 Esports V2: 5 
  • CS UH V2 / UHX V2: 2 
  • GT DD PRO SW: 8
  • CSL Elite SW McLaren GT3: 37
  • CSL Elite SW McLaren GT3 V2: 47
  • CSL Elite SW WRC: 4
  • CSL UH, CSL UH V2: 8 
  • CS P V3: 1.35
  • CSL Elite Pedals V2: 1.6
  • CSL Elite Pedals Load Cell Kit: 1.13
  • CSL Pedals Load Cell Kit: 1.8
  • CS USB Adapter - Handbrake: 1.10
  • CS USB Adapter - Shifter: 1.12
  • CS USB Adapter - CSL Pedals: 1.1
  • CS USB Adapter - CSL Elite Pedals: 0.1

Control Panel + Firmware Manager

  • Fixed installation issues.
  • Fixed USB Pedals getting disabled in the Windows Device Manager after driver installation.
  • Fixed crashes of the Control Panel when no public Fanatec Log folder is available on the PC.
  • Fixed not-working Tuning Menu after continuous mode changes.
  • Fixed buttons still being shown as pressed in the UI after a mode change was done via button combination on the wheel with the UI open.
  • Fixed old Legacy wheels missing the Joystick Input Indicator in Standard Tuning Menu.
  • Fixed APM Clutch input is not displayed on the Steering Wheel page after restart.
  • Fixed Firmware Manager not coming back after manual Steering Wheel Firmware update.
  • Fixed wrong QR Firmware version is shown after updating the QR which triggered another update loop.
  • Added additional check to avoid incorrect update order of the Podium DD.
  • Other minor improvements.


Tray App Version (optional installation)

Latest version of Fanatec App on Android/iOS (V0.1.12+103 or newer) required as well.

More info about the app on:

  • Fixed ITM in the Mobile App not working in iRacing.
  • Fixed FanaLab telemetry in F1 23 not working when the TrayApp is running as well.
  • Added automatic check for new Firmware versions for the CS DD(+) and the USB Adapter.
  • Other minor improvements.


ClubSport DD(+) Firmware Improvements

  • Fixed wheel does not return back to center after base boot.


BMW M4 GT3 Firmware Improvements

  • Fixed green MPS positions 5-12 are pulsing in MPS Constant Mode.
  • Fixed green MPS positions 5-12 are missing inputs in MPS Pulse Mode.


Button Module Rally Improvements

  • Fixed Firmware versions being shown in the OLED every time you re-attach the Wheel.
  • Fixed Clutch Bite Point (CBP) value not shown in the OLED.
  • Fixed Tuning Menu not closing on ClubSport Universal Hubs.

Known Issues

  • When entering a game menu while driving it can happen in some games that the FFB effect doesn't get canceled which results in the wheel turning to one side. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)
  • Natural friction can start to feel weird after some time of driving. In case you experience issues with NFR, we suggest to turn it OFF for now. (this got now fixed for the Podium DD but can still happen on the CSL DD. We will now apply the fix for the CSL DD as well)
  • The steering input jump issue was greatly improved so the issue happens a lot less than before. Full fix expected for one of the next versions.

Compatible FanaLab Version




  • no fix.

    The steering lashes continue (softer per there is) in the first game i have tried ACC.

    Please please please Dismiss engenearing sofware Fanatec.

    Im sorry

  • Driver 455 and wheel base 687 and base motor 41 .........OK!!!!!! No steering lashes.

  • BMR:

    Blue Dial is turning Orange?

    Left Arrow button is turning Red?

    Played an hour of AMS2. I did setup the top 3 buttons to RMP LED button lights set to percentage in Fanalab, but that's about it.

    OLED seems to be working properly on Clubsport Universal Hub now.

    Thank you for fixing Percentage RPM!

    M4 wheels seems to be working fine so far. No odd LED lights like the BMR, but I didn't test it very long. RPM maybe seemed a bit slow? but it did before the new driver.

  • My endurance module still isnt detected. The software hasnt been able to see it since I updated to 454.

  • edited December 2023

    From the logs it seems the BME is somehow bricked as it does not report any Firmware anymore, just

    Did you tried the Firmware recovery tool from within the Firmware Manager already? Did you tried to downgrade back to 451 to try to downgrade the Firmwares?

    That would be the only way to recover the BME, otherwise you need to contact the support.

  • Hello Maurice,

    thx for your reply!

    I have the same issue with the BME since the latest update in 454 went wrong.

    Tried recovery multiple times, but no progress at all, software "hangs" after entering recovery and then fails after some timeout.

    Thinking about trying to downgrade or so.

    Any hints appreciated, as the wheel is not usable at all right now.

    Many thx in advance!

  • What do you mean with "since the latest update in 454 went wrong"? Did the update failed midway? Then the BME is most lickely bricked... Your last chance would be to downgrade to driver 451, downgrade the Base Firmware and then run the Recovery Tool for the Button Module.

    If that does not work, you need to contact the support.

  • This is the reason, why people afraid to update new driver, because the "bricked" issue.

    If someone over the warranty...

  • My BMR shows now the wright settings and also the wright gear or speed.

    Only the Button mapping in wrc 2023 is not corect. I think it is because BMR is recognized as BME.

  • Hey Maurice,

    I'll ask my friend, it is his wheel and he told me that it failed during the FW upgrade witht 454. So I also feared it was bricked.

    But I tried to recover/downgrade with 451 and 450 anyway.

    Like you just mentioned, it didn't work either, so I also am sure it is definitely bricked by now.

    We'll have to contact the support, then.

    Thanks for your helpful comment!!

    I'll update about the final solution asap.

  • still those weird, not centering issues, turn jump and weird FFB. My clutch pedal recognize as on/off switch in ACC, totally not detected in iRacing since v454 as well. Bro it's been a while. If you can't develop a proper software, change somethings in the company or do a proper cocperation please.

  • edited December 2023

    problem sorted sorry for posting

  • edited December 2023

    I’ve installed driver 455 and updated firmware for wheels and rally module,worked fine for 30 minutes,now when I try to switch the base on it cycle’s thru pc ,Xbox and compatibility mode try’s to calibrate and just repeat’s this cycle endlessly,any advice welcome please .if i remove my wheel base act’s fine again so definitely some sort of conflict with rally module and Xbox hub

    Edit only way to turn off base is to unplug from mains

  • f i remove my wheel base act’s fine again so definitely some sort of conflict with rally module and Xbox hub 

    Edit only way to turn off base is to unplug from mains

    just to add if I unplug rally module base and wheel act as normal,so rally module is conflicting with the v2 hub,even if i start unplugged and then plug in module it puts the base into a repeat cycle of the three modes so i cannot plug in to the laptop to see if it works in test mode

  • edited December 2023


    i was upgrading the driver base DD2 from 450 to 454, i followed the instruction and when it asked to remove the steering wheel before pressing ok, i did it, then i pressed ok and the base blocked. 

    Then the base doesn't get recognized and it pop up the screen that u can see called "UPDATE MODE PDD QUICK RELEASE" saying:"Error: Connect device failed(Error: Initial ping failure: No response received for ping command.)."

    If i try to upgrade the firmware pressing the power button for 10 sec, it load the firmware V3.0.3.6.rev4b4c6f9 but it stop again on the UPDATE MODE PDD quick release state.

    Then i completely unistalled (manually and automatically from control panel) all the Fanatec drivers following the guide on the fanatec site.

    Rebooted the PC.

    Disabled antivirus and firewall.

    Installed driver Fanatec_64_driver_336.

    Rebooted the PC again.

    The base is connected only with power AC and to the PC. The steering wheel is removed.

    Launched firmware updater pressing for 10 sec the power button.

    Clicked "start firmware updater". It then show up the Fanatec Wheel Base Updater.

    Clicked "Connect". It detect the Podium Direct Drive Wheel Base.

    It load the firmware V656 successfully.

    Clicked on Flash Firmware.

    It say"Firmware update completed successfully.".

    Then, the Base turn on correctly.

    So i close the fanatec wheel base updater and restart the PC.

    Then i completely unistalled (manually and automatically from control panel) all the Fanatec drivers again. 

    Then i rebooted the PC again.

    If i install the driver 450 it see the wheel base. It say that there is aviable some firmware update as the screen.

    When i click "Open Firwmare Manager" it show that something is up to date.

    It show that wireless quick release firmware is 0. How do i upgrade that?

    If i upgrade something, it will go in the state UPDATE MODE PDD quick release again. 

    On the v450, general update it select firmware V3.0.1.4.revrelease. It successfully upgrade it then it goes on UPDATE MODE: Unknow and ask to power OFF the wheel.

    It goes back again with not recognize the base.

    If i try to manual update, it block.

    The same does if i install the v454 firmware instaed of the 450.

    The steering wheel keep not getting recognized on all firmware. I have 2 steering wheel with different podium hub.

    I also tried to install the driver 455. Same WQR firwmare on 0.

    What can i do?     

  • Your Wireless Quick Release module is broken.

    You need to contact the support.

  • Awaiting my QR2,

    Can the QR2 work on 452 software in case 455 or higher would not work? Because the 452 runs perfectly with my setup.

  • 452 is the worst driver we have ever released and is not recommended to be used.

    However, it would work as a driver has nothing to do with QR2.

  • edited December 2023

    If i try and revert my driver to 451 and firmware will the rally module work on Xbox series x,thankyou

    using a csl dd. 8 nm

    v2 hub

  • No, because the firmware in 451 does not know that the BMR exists so it cant communicate with it.

  • This driver so far no issues and everything working great, love it.

    DD2 user

    But I hope their are new Podium wheel bases in the works with the same CS technology though :D

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited December 2023

    Driver 455 got re-uploaded

    Includes new TrayApp to solve the issue with crashes when checking firmware versions of belt driven bases.

    Everyone who had this issue can re-install 455 by uninstalling the current one and running the installation again with this new one. Everyone else can stay on the previous one as there were no other changes.

  • No, because the firmware in 451 does not know that the BMR exists so it cant communicate with it. This is my driver and firmware,button module not showing and device recovery not working,any advice please

  • Looks like the BMR is not detected which can have several reasons, possible root cause is a faulty BMR in general, a faulty BMR USB-C cable or a faulty USB-C port in the UH V2.

    In any case its a hwardware defect, also judging by your earlier posts, and you should contact the support.

  • In any case its a hwardware defect, also judging by your earlier posts, and you should contact the support.

    ok thank you for answering, i will do

  • Allan LehtlaAllan Lehtla Member
    edited December 2023

    it happened for me aswell, seems somesort firmware update glitch

    what i toto is i added old firmware, and then try again, after that it updated again to latest firmware and then i was able upgrade WQR to 7

    note. was try update 451 to 455

    because there was soo many issue reports from 454 i not even used that for my DD2

  • turbo46turbo46 Member
    edited December 2023

    Hi guys. Installed this version for V3 and CSW 2.5 but since updated from 451 to 454 I had completely different feeling on brakes in iRacing, calibrate but on ice in the longer braking. What can I do? Joycalib modified yet

This discussion has been closed.