Podium DD1 PS4 , GT Sport Game input Freezes after 4-6 min

I have tried updating the firmware and it still gives this issue


  • I read I redit post of some one with a similar issue from back in June , he was supposedly able to fix the issue with a driver RE-Install .

    I have tried this and it didn't work , I am currently on HW:V3 FW: V662

    is there a newer Firmware or instructions how to do a Factory Reset that solves this issue

  • Daniel HaynesDaniel Haynes Member
    edited November 2019

    I had exactly the same. Wheel would freeze after 5-10mins. Only way to get buttons back was to power cycle or remove and replace wheel.

    contacted support and they just suggested rma for replacment, and it was probably an electrical fault. As I live in South Africa and an rma would be a real pain I dismantled the entire wheel to Check every possibility first. The main ribben cable going from the quick release pins to the circuit board has a connector on the end of it that is even held in place with hot glue at the factory in the circuit board... however this was not 100% secure. When I pushed the connector it went into the socket a little more.. maybe just 1mm.. didn’t think too much of it. Rebuilt the wheel and now it’s completely fixed. About 5hrs+ of driving and it won’t freeze at all.

    previously I had spent days trying every driver I could find and software.. but it def a hardware fault.

  • Daniel Haynes , Thanks for your reply , I also live quite a bit far and shipping would be expensive " Trinidad & Tobago "

    This sounds like a similar issue I have fixed a couple times on Logitech G29 wheel bases . I will take it apart this weekend and try your suggestion .

    Cheers Daniel Haynes

  • Having the exact same issue since yesterday...

  • I had this same prob. Was ok for the first few races the first day, then would cut out in 5 mins or so. Since this was already an rma for an issue with the base, I didn't want to open another. The ribbon cable in the wheel connecting to the base pins was pushed in tight, but I decided to push in each wire individually to its max in the connector.

    I have done one 20 min race and all is good so far. Will update if the issue comes back.

  • Is there a guide on how to fix this? The procedure sounds complicated

Sign In or Register to comment.