FanaLab 1.23 beta Download - Post your Feedback here

1356721

Comments

  • edited December 2019

    My only issue with the new FanaLab version is, that if i played RaceRoom or any other Simulation with the specific FFB Settings i created and then switch to ACC as example, all my Settings on my DD1 for ACC are randomly changed and mixed with the Settings from the other Simulations.

    So if i load the Settings for a specific Game, i have to double check if the Settings are still correct or completely broken and mixed up. Has anyone else had a issues like this?

  • I do not see FanaLab 1.24 listed under the Fanatec Software/FanaLab.

  • More info about my previously reported problem where Fanalab crashes very quickly following its launch. I have two Errors in Windows Event Viewer:

    1) .Net Runtime Error:

    Log Name:   Application

    Source:    .NET Runtime

    Date:     12/26/2019 7:29:33 AM

    Event ID:   1026

    Task Category: None

    Level:     Error

    Keywords:   Classic

    User:     N/A

    Computer:   simrig

    Description:

    Application: FanaLab.exe

    Framework Version: v4.0.30319

    Description: The process was terminated due to an unhandled exception.

    Exception Info: System.DllNotFoundException

      at PodiumControl.PCThreadGameTelemetry.GteDllGameLaunchDetectStart(System.String[], Int32, CallbackGameDetectorStringParam)

      at PodiumControl.PCThreadGameTelemetry.Start(PodiumControl.PCGameTelemetryDataJsonShared)

      at PodiumControl.WindowMain+<PrivateInitialize>d__9.MoveNext()

      at System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c.<ThrowAsync>b__6_0(System.Object)

      at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

      at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

      at System.Windows.Threading.DispatcherOperation.InvokeImpl()

      at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(System.Object)

      at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

      at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

      at MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)

      at System.Windows.Threading.DispatcherOperation.Invoke()

      at System.Windows.Threading.Dispatcher.ProcessQueue()

      at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

      at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)

      at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)

      at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)

      at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)

      at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)

      at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

      at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)

      at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)

      at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)

      at System.Windows.Application.RunDispatcher(System.Object)

      at System.Windows.Application.RunInternal(System.Windows.Window)

      at System.Windows.Application.Run(System.Windows.Window)

      at PodiumControl.App.Main()


    2) Application Error

    Log Name:   Application

    Source:    Application Error

    Date:     12/26/2019 7:29:33 AM

    Event ID:   1000

    Task Category: (100)

    Level:     Error

    Keywords:   Classic

    User:     N/A

    Computer:   simrig

    Description:

    Faulting application name: FanaLab.exe, version: 0.0.0.4, time stamp: 0x5df750e3

    Faulting module name: KERNELBASE.dll, version: 10.0.18362.535, time stamp: 0x5bd9df62

    Exception code: 0xe0434352

    Fault offset: 0x001135d2

    Faulting process id: 0x117c

    Faulting application start time: 0x01d5bbe81e4706b7

    Faulting application path: C:\Program Files (x86)\Fanatec\FanaLab\Control\FanaLab.exe

    Faulting module path: C:\Windows\System32\KERNELBASE.dll

    Report Id: 4525e0bb-690f-4f42-91bb-c5fe593d4600

    Faulting package full name: 

    Faulting package-relative application ID: 

    Event Xml:


    If I can help resolve this in anyway, please let me know. I really want my OLED display and shift-lights to work again.

  • As posted by Jacob Stig Bruntse Nielsen It ruins my other wheel of choice.


    This defeats the whole purpose of having a Formula and an endurance wheel. Extremely disappointed. 😫

  • Hi there.

    Since i installed Fanalab v1.23 Beta, and upgraded the firmware on my DD1, everytime i power off the wheel base or disconnect the USB without closing the Fanalab first the windows 10 crash. I have try to troubleshoot the issue, and i can reproduce every time. It does not occurs if i the fanalab isn't running.

    Here's my info :

    DD1, CS Universal Hub, CS Pedals V3, CS Shifter SQ 1.5, CS Handbrake V1.5​,

    Fanalab v1.23 Beta

    PC driver : 352

    WB FW : 669

    WB MF : 38

    Cheers

  • Some people have that problem. FanaLab and the drivers have a bug. Fortunately, you can avoid the Windows crash by closing FanaLab.

  • I've treid the new beta but it is still a bit to buggy for me. I experience random crashes of the app while playing a game or adjusting a profile. Made profiles somehow interfere with iracing and rfactor settings causing a different feel of the car under same conditions. Rev lights (pit) doesn't work well in iracing. It shows up but only when you drive away and hit the limiter?


    I use a Podium DD1 F1 wheel and play iracing, rfactor and ACC.

  • I have also the issue, that fanalabs does not launch. Is there now a solution for this problem out there ?

  • edited December 2019

    I love the new software, great step in the right direction.

    2 Things though,

    My break pedal vibration is not working in game after the upgrade. Tests fine in the Game Controller driver window and even kicks on outside of game at the proper pressure set in the wheel. However, when I load any game it stops working all together. I get no vibration from the break pedal. I tested this in ACC, AC1, iRacing and RFactor 2 (see attached screen shot of ABS vibration settings).


    2nd is that iRacing does not seem to like the new software. Most of the menu options for vibration section are not available. I tried re-creating the game profile, but as soon as I launch the game the options gray out. (Screen shots) below on that. Is this normal for iRacing? Does it just not have the telemetry out-put to support it?

    Also a vibration preview for each option in the vibration menu would be very helpful.


    Thanks,

    Brian


    Hardware:

    CSW 2.5

    F1 V2 Wheel

    CS V3 inverted Pedals



    Edit: added hardware used

  • edited December 2019

    1. It's not possible to use the Tuning Menu ABS setting anymore together with Fanalab because FanaLab uses telemetry based pedal Vibrations and overwrites the fake setting of the tuning menu. Therefore if you have set abs in the tuning menu as well as pedal Vibrations in FanaLab this will get in conflict.


    2. That's due to the very strict restrictions of iRacings telemetry. The iRacing devs decided to hide almost everything from their telemetry data to prevent possible cheating. Nothing FanaLab can do, it's iRacing which needs to open their telemetry so FanaLab can access the needed data to get everything working.

  • Thank you. No problem I support iRacing's endeavor to keep iRacing cheat free. I"m also OK if Fanatec can not provide the same features they provide to other games with iRacing eSports.


    Is that why the yellow caution lights don't work with the 2019 F1 when the white, green and blue flags are working? Tested with the F3 and RSR.

  • Is it possible to implement an internal data recorder which shows the nm, Fan, temperatures and everything the DD could show in a graph?


    Would be cool.

  • Why aren't the flags working on rf2? Crew chief supports the flags so I don’t understand why it’s not working on the BME (using driver and FanaLab 1.24 beta out of the driver package) remaining fuel on the display would be nice as well 😊

  • Where can i get 1.24 beta? would like to test if it works with this version.

  • DD1: with the driver 353, Base firmware 670 and motor firmware 38 I installed fanalab 1.23. Now in AC I have during driving a permanent strong vibration. Without fanalab it woks fine. Deactived all in the vibration menue, but nothing helps.

  • Turn the INT value up to 6, it's most probably set to off in your case because you loaded a FanaLab profile without INT.

  • I have the INT to 4 and with 6 its the same. ABS is in tuning menu in the wheel also off.

  • I'm currently experiencing bluescreens in iRacing. Sometimes it happens when I start the Sim or change in iRacing from "Open Practice" to "Practice" or I drive a complete race and Windows crashes while watching the replay.

    Bluescreen:

    DRIVER_IRQL_NOT_LESS_OR_EQUAL

    FWFilterUsb.sys

    I'm not sure if this is a FanaLab problem but it started when I switched from CSL Elite Base without FanaLab to Podium DD2 with FanaLab.

    Yesterday it happened with driver 352 and FanaLab 1.23.

    Today I installed driver 353, firmware 670 and FanaLab 1.24 and it crashed after the race watching the replay.

    I'm using DD2 with Porsche 911 GT3 without BME (it should be delivered tomorrow!)

  • Is there a way to change the screen on the DD1 without a setup button or funky switch on the wheel? I have the Podium R300 and I would like to be able to use the new functionality of the screens to replace the display that is missing from this wheel. And possibly to augment the screens on other wheel rims.

  • Can it be added to a future version of Fanalab? Or the driver package?


  • In fanalab for iRacing it says that you have to uncheck the fanatec led graphics in the graphics settings in order for the wheel leds to work in iRacing.

    For me, it seems to be the opposite. They don’t work until I have the box checked. Anyone else experiencing this?

  • No. You have to disable the in game led checkbox in order to get the FanaLab leds working.

  • Right, I see that’s what you’re supposed to do but I’ve tried with both F1 rim and Podium Porsche rim, and leds don’t turn on AT ALL unless I have that box checked, that’s why I’m confused. They seem to actually work correctly when I have the box checked

  • You obviously have to setup the leds in FanaLab according to the car you are driving. If nothing is lighting up you might have the leds setup with a too high percentage value.

  • hmm maybe. I’m still a beginner on iRacing. Is there anything wrong with leaving the box checked, since that seems to make it operate properly for me?

Sign In or Register to comment.