On DD1, Handbrake work in CWS2.5 mode, but not in PC mode

Whenever my DD1 in PC mode, the handbrake axis as shown in the "Fanatec Wheel Properties" cannot be controlled by the handbrake, but by the "Rotary Encoder" on the wheel. When it switch to CSW2.5 mode, it works normally.

I have this problem on Driver version 352 and 347. It is normal in 346.

Anyone encountered this problem?


  • Yes, I have this problem too. Same equipment. Only noticed it last night when I tried to dirt track race. My handbrake is connected to the V3 pedals which are then connected into the DD1. When I go into controller properties it shows the handbrake as on, 100%, and does not recognise any input from the handbrake itself. When I disconnect the pedals and handbrake from the DD1 and instead connect it direct to the pc then turn the DD1 off, then go to properties, i can see the handbrake and it works as normal. The problem for me seems to lie with the DD1 base, when it is connected in any way to the handbrake or even just turned on when the handbrake is plugged in, it effects the handbrake somehow. I have tried updating all firmware and uninstalling and reinstalling it all with no luck. I really am at a loss with it so have submitted a support ticket.

  • did you get any solution? i am having same problem, i have last drivers, handbrake do not work connected to dd1 base directly or USB adaptor to pc, it doesnt work anyway, even through v3 pèdals. since i have changed to dd1 base all are problems, im really disappointed. im desmotivated when i try to play any simracing game.

  • Ade AllenAde Allen Member
    edited April 2020

    Same problem here too, doesn't matter if I have the Universal Hub or Formula v2 connected.

Sign In or Register to comment.