Multiple Input Detected

Hi, I keep getting the Multiple Input Detected if I try to set the steering axis on the CSL Elite on my PC for AM2 (also the same happens in PC2).

I did update to 402, unpluged everything, deleted the files in the MyDocument/Automobilista2 Folder . The Issue stays the same - Pedals are fine, buttons, shifting, all ok - just the steering wont work and cant be set or callibrated - its driving me crazy.


  • That has nothing to do with Fanatec or the driver.

    You have bound one axis to two different functions.

  • I don't think Michael is correct here - I had a similar issue in AMS 2 but it was easy fixed - I had a latching switch on a button box that was sending a constant signal - so the game saw the switch and the steering axis. Are you sure you don't have a switch or encoder sending a constant signal (i.e. encoder set to constant, latching switch) on a button box or wheel?

    The only other thing to check is you aren't inadvertently pressing a pedal and you don't have a cat sitting on your keyboard.

  • Marc ReisMarc Reis Member
    edited March 2021

    Thanks for the tipps!

    @Michael Meßner: I have of course done multiple things before posting, defaulting setup of the wheel, driver updates, deleting the documents folder of AM2 and so on - so if there is no bug in the driver, then there should be no double on the steering axis.

    What brings me to drivers is, that it used to work, so on the way of AM2 being updated and fanatec drivers being updated some time in the period fall 2020 and start of 2021. Also its not working in a clean install of PC2, which i did again just to see what it does. I guess some driver and game specifis going bad - it works fine in every other game (ACC, DIRT2.0, FH4, and so on...).

    @Gary Johnston:

    I did unplug everything except the wheel, mouse and keyboard (also detached the plug from the pedals, just to be sure). The only thing that i can see sending input (I have not used any specail tools... which might be next to do ) is the "Analog Joystick" on the F1 Wheel. At least in the USB Game Controller Driver Window, I can see that they are for x and y at 50% (0 is not possible for both axis). But as far as I remeber that has been the case since day 1. (See the picture below for what i mean).

    So it must be some kind of issue that is specail to the AM2/PC2 Engine and the Wheel/Driver.

    Edit: I also banned the cats - just in case ;-)

    Edit: I also am using VR - so I have also disapled the steam VR controller stuff and have switched to pancake to setup the wheel, just to be sure nothing is comming from that area.

  • What I did notice, just remembered, that the wheel shows an update button, but can not be updated since the button can not be pressed. I thought that it ment that only those specific wheels can be updated and not my "F1" default wheel . I thought I mention that , just in case.

  • Oh and also I used this to check for any signals...

    but turning the wheel only shows the wheel as input

  • Weird one, I have had issues when using gaze control to assign functions in VR in AMS2 so now use the mouse and things worked fine. The other thing to try to get you up and running again is if you clear all bindings then reselect your wheel base it will automatically bind the standard controls, ie. gears, pedals and steering so you don't actually need to assign these manually. You will need to assign the other buttons though but hopefully you won't have any issues with those.

    BTW - the firmware manager showing your wheel with a non selectable update button is just down to poor UI design. This has confused a few people.

  • Thanks Gary,

    I had gaze control in usage also - turned it off at the start of the trouble shooting. The Problem seems to be that multiple inputs, for what ever reason just screw up any asigning bound to the steering. I cant even calibrate it, it will just stick at "0". Is there a way to clear all inputs? I can reset to default or use the "custom" but even on custom and first thing going to left or right steering produces the same effect.

    The reason I wanted to reasing was, that I want to go for a quick drive and hit the wall end the end of the box since the steering did not work (but shifting, gas, break e.g. do.) Its really strange, especially since its the same on the clean install PC2. So it looks like an engine <-> driver kind of thing, may be also some windows update joining the game. I also had some trouble before with OneDrive messing up things since it wanted to push stuff in the cloud only - I did stop that for the AM2 folder.

  • Just in case, is it normal to see two entries for the FANATEC CSL in the Gamecontroller? Its always been like that if I remember correctly....

  • Yes it is normal to show 2 entries

  • Ok, Thanks @Alexandros

    @Garry you are not by chance using a CSL Elite with AM2? I wonder if its some stupid combo of Windows/Drivers/Other Devices that is causing it or a general PC2/AMS2 Engine and Driver Problem...

  • I'm using a DD2.

    Try resetting to default settings in AMS2. Then back out of that menu. Then go back in and select the Fanatec preset - then back out again. That should automatically bind pedals and steering so you don't need to manually bind. if that works you can then bind other buttons - make sure you don't accidentally turn the wheel when binding other functions though, or you will bind the steering axis to that function and be back to square one.

    Good luck - I feel your pain!

  • In Short - its Solved - Thank God and Thank you all

    In longer:

    I started doing updates again for the Chipset, GPU, and so on - I used the Ryzen AMD Tool (for CPU/Chipset, instead of Asus stuff). Changed noting at first. I unplugged everything again, checked nothing and so on, the usual last hope stuff.

    After I did that again a second time and was fiddling in the USB Controller Setup (Windows) it popped a notice after a Wheel Plug/Unplug/Plug that shortly showed something with "Firmware Manager ..." (Fanatec). And then that I would need to power off and on again the Wheel. I went in game and again nothing, kept switching between calibrate and setup - and there the first change appeared on 2nd try (calibrate, assign, calibrate) It said I would need to assign the correct axis first. I went back to assign and then it took the axis!

    So still not 100% Sure - a combination of stuff I guess - Fanatec Update, Windows did some updates and I guess AMD for the Chipset (USB Controller) - something must have gone weird some time the last month and got unstuck now with the updated and plug/unplug action.

    I guess it was the Fanatec driver, worked for other games, but maybe whatever the PC2/AMS2 engine is checking did not work out.

    So Thanks for sticking with me and helping with your Tipps and expertise - now it’s finally time to spend all those hours in racing again. :-)

  • In my case that did not work - if I used default the steering would just not work in game, also not in calibration.

    I guess the way AMS2 uses the wheel it for what ever reason did not get it the way it needs it do to maybe the last firmware update or something not being fully pushed to the wheel - no idea why the other games did not bother - but at least now its working and finally racing time again :-)

  • If you get the issue again an easy fix (which i forgot earlier) is to delete the AMS2 folder in your documents folder. That effectively puts AMS2 in a clean install state - when you fire it up again the folder will be instant recreated but all graphic and control settings deleted.

  • I did that multiple times, the files and also the folder - that had no effect -

    Seems to have been a true driver and programm issue in some locked up combination.

    After that was "sorted/cleaned up" all stuff in AMS2 works.

  • Two issues that leave me so upset that I’m just about ready to sell $3000 of Fanatec hardware….and I am convinced no one else seems to give a darn about these issues, as in 30 years no one ever mentions them, or if they do the mails are censored.

    First is Fanatec’s idiotic login….most of the time a customer sees this feedback : “Your access data could not be assigned to a user”. Yeah….right. No one knows what that means, since the folks in Germany apparently can’t afford to hire a translator.

    After a year I discovered it means the customer (paying all their bills) has entered data into a foreign web site. Of course the URL DOESN'T INDICATE THIS…IT ALWAYS STATES FANATIC.COM


    Second, and most importantly, they (and EVERY OTHER SOFTWARE FIRM) write lousy code…there used to be an expression, “actions have consequences”. But no more. Apparently no one ever gets fired for poor work…might hurt their feelings. The result? Crap Code. Bill Gates said 30 years ago that one great coder is worth 1000 average coders. I wonder where they all went?! OS code is so bad it gets updated weekly…only to discover more errors have been introduced. How can these folks show their face?

    Bottom line - this forum or blurb, whatever it is, Is worthless. As are all of them.. . It’s the blind leading the blind. AND THE MOST FRUSTRATING THING…..NO ONE EVER EXPLAINS WHY OR HOW THE PROGRAMMING ERRORS OCCURRED,

    folks exchange suggestions, as what else can they do? The coders can’t fix it, ‘cause they don’t even know what they did wrong….and why bother….they keep getting a paycheck, so why worry?!

    they should be ashamed

  • I'm guessing this issue has long since been solved, but I recently purchased AMS2 and came across this issue as well when setting up my initial bindings. I discovered that it was due to my having turned on the setting for "Enable Analogue Inputs in Menu" (in the Configuration tab). Turning that off allowed me to bind everything with no problem.

Sign In or Register to comment.