Podium DD2 danger issue!!!

Hello to everybody I'm Andrea from Italy .

Today i received my DD2 i updated driver firmware as described by Fanatec I installed Fanalab and than i went in iracing to drive .

after one minute my steering wheel without any reason go full on the left with the full torque!!!!!

really dangerous because i was on a straight line!!!!

i tried to change usb input of the wheelbase but nothing is changed!!!!

does someone had the same problem?

I don' want to try again because is really full torque ( and i lowered the ff to minimum in fanalab)

Please help me 😓


  • this sounds like the old freezing issues. which driver did you install?

  • Sascha... i have the same issue....i try to manage the issue with Fanatec for second week ....have dd2 recieved 2 weeks ago....same same issue.....i dont know anymore what to do... :( :( :(

  • i tryed this ass they described on mail...but did not work for me...

    Please follow the instruction step by step (very important).

    -Make sure all your PC drivers (especially chipset) are up to date.

    -Remove the steering wheel and disconnects all pheripials from the wheel base and disconnect all your sim hardware from PC (even if it is from another brand).

    -Uninstall the Fanatec driver from your system.

    -Reset the wheel base to the default settings according to the instructions included. (reset game controller to default.pdf)

    -Disable ALL anti-virus software including Windows Defender.

    -Look for Windows Update. If available, please install it.

    -Download driver V402 If you have already downloaded it, please download it again.


    -Install driver package V402 and restart your system.

    -Disable ALL anti-virus software including Windows Defender once again.

    -Open the Fanatec Wheel Property Page and perform the updates for the wheel base and the motor and perform the motor sensor calibration (do not attach the steering wheel yet).

    -Once the wheel base and the motor has been updated sucessfully, please close all the windows, restart the PC and the wheel base.

    -Attach the steering wheel and connect all the fanatec hardware only and update the firmware for those devices (if available).

    -Open the property page again and check if the issue could be solved or not.

    -Now you can connect all of your sim equipement and check if the issue reoccurs. If so, than you will know what could cause it.

    Please let me know the outcome.

    Thanks in advance for your understanding and patience.

    Best regards / Freundliche Grüße


    (Fanatec Support Team)

  • Might be a stupid question since I am not in iRacing, but have red before that in-game settings are a bit strange and need constant changes every time there is an upgrade from the developers. So what in-game settings you have? If you post them, then someone more relevant with the game might spot something that causes the issue.

  • Hey Andrea,

    I have the same problem as you and Miroslav. I got my DD2 Last week so maybe this issue is with a recent batch?

    Worrying though because this problem maifested itself within a minute of first using the base. When spending so much money on a product I'm surprised that more testing is not done to ensure a good customer experience...

    Regardless, hopefully fanatec will help us all quickly and get these problems resolved.

  • I have the same issues Ive had my DD2 for two days. On two occasions it has went full torque to the left for no reason, causing me to have to used the E-Stop. I have the latest drivers. I hope this is a software issued and not hardware related. But this obviously is not an isolated problem.

  • Just to follow up on this if anyone stumbles across this issue, Fanatec were able to very quickly resolve my issue with an RMA, only took a few days and everything is working 100% now.

Sign In or Register to comment.