Unable to log in

So I am starting a new thread for this, I have been trying to get into my account since lunchtime Friday, I’m uk so using the eu site, nothing is working I’m only getting text loading, I have cleared my data and trying on 5 different systems and still can’t log in is anyone still having the same problem, and if you solved this problem please let me know how you did it, I’m trying to see my DD info and get a new wheel?

Edit: I forgot to add, all the other regions work just the EU site I can not login.

Comments

  • Site is working fine. Could log in to my account too. 👍

    Could see everything on the website as well with “availability” in the future for the usual suspects.

    Wishlist is still there.

    All ok sticking stuff into the basket as well.

    … And… as I was there… there was a “warning” that there is a “significant delay” in UPS handling due to Brexit.

    Hence why I have not received my shipping tracking number even though items all gone through the warehouse.

  • I’m not sure what is going on I can go to all the sites except the EU site ?

  • Try with Firefox, that worked for me. I have the same problem with the EU portal if use Chrome or Microsoft's chrome-based browser.

  • Hi thanks Jeremy ford, but I’m using Firefox I have tried using 5 different systems and chrome/explorer and tried iOS and windows but no joy 🥲

  • So I can log in but every thing is in text form, I really don’t understand what is going on, I can see the other sites but not EU, I have cleared the cookies ad tried different computers so it must be a setting on the site,

  • Jeremy FordJeremy Ford Member
    edited October 9

    That is strange, as said I get the very same problem with Chrome, but not Firefox. And it's specific to the EU website, the US portal is working on both browsers. Try opening the https://fanatec.com/eu-en/ page in private mode, I just discovered I can get it to render properly in Chrome using this method. Weird stuff.

  • David ChiengDavid Chieng Member
    edited October 9

    Now that I think of it...

    It only works through Safari. (IOS) Does not work through chrome on my PC.

  • Hi guys, I’m losing my mind, I have tried all of the solutions I can log in but it’s not loading the html- or pic’s only text it’s not even loading the avatars next to your names in the forums now, I just don’t know what to do, I have even tried to use my phone on data so it’s definitely not my connection?

  • How about you just take a breath, step back, relax and try tomorrow. You’re acting like it’s the end of the world.

  • hi joshua, its been one of those days i just updated my 3d printer with a bltouch only to find there is an issue with the firmware, so now its a paper weight till i fix that and then i can't order the wheel i wanted and that’s been going on since Friday lunch time, and to top that im looking after next doors dog for a week as they are on holiday and it’s a royal pain in the ass.

  • Same here, EU site not working in Firefox and Safari on Mac and iPad.

  • Whew…..then most definitely, just step away for the evening. It is honestly not worth the stress.

  • edited October 10

    Tried a bit more.

    On Windows using Firefox, Edge, Chrome and Opera I can't access my account and I only get a text version of the home page.

    On iPad the same thing happens with Safari, Edge, Firefox, Chrome and Opera.

    On Mac the same thing happens with Safari, Edge, Firefox and Chrome.

    But I was able to place an order with Opera on the mac.

    The US website works fine though but I need the Europe one to order.

    I hope Fanatec gets their website fixed soon.

  • I can get onto the website using my ipad and samsung phone, but not from my PC.

    May need to wait till Monday for someone to sort it out.

  • Fixed! :)

Sign In or Register to comment.