Podium Button Module Endurance Tuning Menu Issue

Hey everyone

I recently got my hands on a Podium Button Module Endurance and the wheel and module are epic. The only glitch I seem to be having is with the tuning menu. I can enter the menu easily. You just push the little button to enter. However, once I'm in the tuning menu, that button becomes unresponsive and will not let me exit that menu. No matter how long it on, or what game I try and enter, the display stays in the tuning menu. It also is a challenge to adjust the ITM screens because when pressing the tuning menu and moving the funky switch, the button module wants to go right into the tuning menu.

I'm sure I'm overlooking something. Just not sure if I'm the only one with this issue.


  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Roy,

    Please ensure that all firmware is up to date (base, hub, BME). If everything is already up to date, or that doesn't help, please contact technical support by opening a Support Ticket via the My Products section of your Fanatec account. Please provide as much information as possible: which wheel base you're using, driver version, firmware versions of all connected products. A video demonstrating the issue would also help.

    [Fanatec Community Manager]

  • Thank you for the reply. According to Fanalab the software is up to date. I might even try other software versions first to see if that helps. Just wasn't sure if it was happening to others as well.


  • Fanalab has nothing to do with the drivers. Also, the driver doesnt automatically check for new updates - just what is on your hardware.

    What driver version are you running?

  • Sorry, Darren you are correct. I meant the Fanatec Firmware Manager. I'm using PC driver version 415 and the BME firmware says its 18 and up to date.

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Roy, if everything is up to date, please open a support ticket as described above.

  • Jurgen KuselJurgen Kusel Member
    edited November 2021

    Glad it's not just me. I have the same issue and I'm also fully up to date. Been driving me mad.

    Occasionally it will work as it should but more often than not it gets stuck leaving me with no display ! Last two days in a row I've been stuck.

    Reboot will clear it but then again if I try and scroll to ITM it will get stuck again as shown. ITM is a key feature and was one of the reasons I sprung for a very expensive button box, so to not be able to use it is infuriating.

    Hoping for a quick fix from the team as seems we have found a pretty substantial bug.

  • Dominic BrennanDominic Brennan Member, Administrator

    Hi Jurgen,

    Could you try to attach your video again? It is showing as an image.

  • Update for me

    Last night while playing around with it, I had the issue initially. I was in the process of submitting a Fanatec request. For some reason I think I had been more concerned with the ITM than the actual tuning menu, so after a reboot I tried to enter the tuning menu first before getting into the ITM screen. To my suprise, I was able to enter and exit the tuning menu normally. Then once I tried to enter the ITM menu and adjust the screens, it all worked properly. I was hopeful until I saw Jurgen's message. I will try again tonight and report back. Yesterday anyway, things worked well afterwards.

  • I'll take another video for you, did a screengrab as original video caught some background stuff I didn't want to share 😂

  • Hi,

    I can exactly reproduce your story.

    Turning on the CSL DD, starting Fanalab and enter an ITM menu let the BME stuck in the tuning menu. The only way seems to be rebooting the base then.

    But if I switch the base on, enter a tuning menu, then leave it, after this starting Fanalab, everything works fine. Then it is possible to enter the ITM menues.

  • Ever since I did that, the wheel has been fine and I've been able to access both the tuning and the ITM menu. Not sure why, but that has seemed to have worked for me. If this can help anyone else, that's great.

Sign In or Register to comment.