Clubsport V1 Pedals calibration changing during play

I know these pedals are old but I am hoping someone here might still have a solution. I have a problem where the brake calibration seems to change during play. Over the period of about 20 minutes of driving the pressure required to achieve full braking becomes more and more. I have installed a new load cell but still have the same issue. I am using the pedals stand alone going directly into the pc. I am playing assetto corsa competizione and assetto corsa, getting the same issue in both.


  • If I disconnect and reconnect the pedals the calibration is reset but then drifts off again during play as above.

  • Hmm that's strange. I have the same pedals that I use with my CSL DD, and haven't noticed anything like that. I am using a PS/2 to RJ-12 cable to connect them directly to the wheelbase, though. Maybe it has something to do with that? Did you maybe try using a different USB cable? How long is the cable? From what I understand, anything more than 6ft or so can start to introduce problems.

  • Thanks, I tried changing the USB cable but the problem is still there. I have cleaned the sensitivity pot and checked all connections with a multimeter and they are all fine. It's like the calibration isn't getting locked in. Possibly a software issue with them being so old. The current fanatec driver doesn't give me options to set min/max, or to set anything for that matter, I can just see the inputs from the pedals but I have no options other than test vibration. Is there any way I can trick the software into thinking they are V3 pedals so I get the min/max set buttons?

  • Not as far as I'm aware. Are you able to use an RJ-12 cable instead of USB to see if maybe that has something to do with it?

    Other than that, short of contacting Fanatec support, I don't know what else to suggest.

  • What driver version are you using? - maybe you can drop back to an earlier version

  • I solved it by doing this. At first I used the original Fanatec load cell amplifier and the problem was still there so that was the issue. I replaced it with an HX711.

Sign In or Register to comment.