How about fixing the EU website?

As the title says.

It seems like for the best part of a year the website has been unusable 70% of the time.



  • Working fine for me.

  • Thanks. I've just checked on my laptop and it is.

    The above image is what I've received most of the time since June (pixel 4).

    Just tried an old Huawei and is working fine too. Strange that this website is the only one I've had issues with. Couldn't contact support last week because of it- and they don't seem to be too active here.

  • I have all sorts of issues with the EU website and have done since ever. One minute it works, then it just times out, then you can't login etc etc etc

  • In layman's terms - The website breaks far too frequently - it is still up but the content is incomplete. This means that the broken version gets stored either in your ISP's cache, your browser's cache or both. So many users continue to see the broken version even after Fanatec finally get round to fixing the issue. In your case, it seems that the your issues are with the browser on he affected devices, not your ISP. In either case though, the solution is the same - force your browser to freshly reload the page. The exact process varies by browser and platform - google "force refresh webpage" and "clear browser cache".

    While you do that, Fanatec can google " how to maximise website uptime". :-)

  • Dominic BrennanDominic Brennan Member, Administrator

    We are currently deploying some fixes, site should be restored soon.

    [Fanatec Community Manager]

  • Hi,

    So yesterday morning/afternoon it worked fine, however it was broken at night. I did some digging and found out that the .css file (that is responsible for the layout and styling) that is loaded is an empty file.

    At the moment, the EU version is loading:

    And the US version is loading:

    At the moment the EU version is thus empty and the US version is not, and therefore the EU website is malfunctioning whereas the US version works fine. I think this does not have anything to do with the user's cache since CTRL+F5 (force refresh) is not changing anything.

    I don't know what method Fanatec uses to update their CSS file, however I get the feeling that when they update it, the old css file gets removed and a new one is created. And somehow the url to the css file on the EU website is not updated. As it regularly malfunctions this is a potential cause, however I could be completely wrong.

    Please have a look into this. Thanks in advance!

  • EU website seems to be broken again for days.

    Need to contact support and tried since friday to get to the website. Also tried refreshing cache and opening the site on my mobile device but I only get the plain white text style site.

    US and Japan sites are working though

    Please, please fix it!

  • EU site works for me.

  • for me also not working. I'm trying now for several days to order but it's not possible. Please fix the website. I wanna give you my money!

  • Yeah same for me. With waiting for site to load i get so far that i only need to paid for it but when i try to proceed to checkout it wont load at all.

    5 days of trying and nothing.

    At least i see here that im not alone.

Sign In or Register to comment.