Fanatec Driver 439 (Public Release) (435-437 before) for CSL, CSW and Podium WB (all wheels)



  • Yep, can reproduce. Its an issue of the Firmware V44 of the McLaren Wheel.

  • Same here. The right analog paddle works like a 0/1 switch now.

  • edited January 2022

    already reported internally.

    It is an issue of Firmware v44.

    Everyone with a McLaren Wheel should stay away from this driver until its fixed with a new driver (or alternatively skip the update for the Wheel so it stays on v43 which still works fine in general with this driver and included Base Firmware).

  • Is it the only known issue with a mclaren wheel? I don't use this paddle anyway so I can live with it for now.

  • No, there is another long standing issue with the McLaren GT3 v2 wheel. Button 7 & 8 were eliminated at the firmware level. So there is no physical button 7 or 8. For games like F1 2021 where button 7 & 8 are key to the game and their functions can’t be remapped. This means you can’t use the McLaren wheel to fully play/navigate the game; you have to have a keyboard.

  • edited January 2022

  • Goodnight ! I just upgraded to v435. and now I have problems with the ffb. I have the feeling that it feels strange to drive it. I want to go back to v434. I have to download v434 delete v435 from the pc and update it manually right? I do not want to damage the base dd1 ps4. a greeting

  • Hi All, Just to let you know the Firmware for the GT3 is messed up.

    My DD2 wheel base is now, with the GT3 wheel installed no longer recognised, and says new wheel foud " Fanatec Clud Sport wheel"

    Also the Right Analog Padle is now configured as on off switch, so cannot be used as a Hand Brake.

    Please fix these issues, We are unable to use the GT3 Wheel as intended.



  • Thank you guys, my RevLeds finally work on my PBME connected to UVHX2 and CSL DD! Awesome.

    By the way, the firmware section in the first post says "Podium BME: 10 (NEW)" while it should be 20.

  • I agree, too bright for a dark room but thanks A LOT for the tip the brightness setting is actually available in the PWS file! 🤩I knew there were plans to maybe include brightess setting in FanaLab so I assumed it's not available even as an attribute in the config file.

    For those intereseted there are three sections where you would find <Brightness>100</Brightness> line and adjust the number 100 to your liking from 1-100:

    <RevLed> - standing for RevLeds on the wheel; <RevLedBase> - standing for RevLeds on the base; <LedFlags> - standing for LedFlags on the wheel

    I own Fanatec wheel since very recently so I started with v429. Has this setting been available since ever/very long time or is this a new addition pointing that maybe brightness setting is really closer to get to FanaLab?

  • edited January 2022

    This hidden brightness stuff in the pws files is available for 2 years... ;)

    And yes at some point, maybe this year, the brightness adjustability gets exposed in Fanalab itself :)

  • I'm using a set of CSL Pedals with the ClubSport USB Adapter. I've been trying for days and days to get them working but to no avail.

    With this driver, the pedals are finally recognized by Fanatec Control Panel (even though the picture displayed is the one of the CSL Elite Pedals), but the pedals are still not working. I'm desperate to get them to work. I've tried flashing the ClubSport USB Adapter, removing all my USB devices, etc.

    Maybe a future firmware will help?

  • good !! Yesterday I updated my dd1 to v435. and when driving again my sensations were very strange compared to v434. so i have downgraded to v434 but i have not downgraded formula wheel firmware v2 (ps4 dd1 ). now I have 44 and I seem to remember that before it was 43 in v434. can i leave it like this? or would I have to downgrade the steering wheel firmware? a greeting

  • Hi - I have a question about these jolts on the DDs.

    • I have a DD1 and use either the Porsche Podium wheel, or Formula V2 - BOTH HAVE A PODIUM HUB
    • I typically only iRace, and I have my DD1 set to 100% FFB in Linear Mode inside Fanalab
    • I also have ITM Mode Disabled
    • Inside iRacing, I have the torque output set to 20nm, in linear mode.

    However, due to bad tendonitis in both arms, I typically use a MAX FORCE setting in the iRacing settings at between 60nm and 120nm depending on the car I'm driving and how bad my arms & wrists are feeling at the time. So it's scaling that 20nm by three to six times.

    Is that why I am not experiencing the reported jolts because I'm not truly exceeding 20nm? Or am I just lucky? I am just curious, and wondering if somehow I am actually getting these jolts and thinking they are just FFB?? I highly doubt that, but again, I'm curious + hopefully, it helps Fanatec to figure out the issue by knowing what kind of circumstances it's NOT occurring in.

    I APPRECIATE THE INFO, Thanks to both of you!


    So far, everything has felt fantastic on the new firmware and drivers, and I've had no issues.

  • Like Gary also mentioned, this is something that is going on from day one the Podium bases where released so it's not like "some bug that was introduced somewhere last 3 months" ;) It's already there for MORE than 2 years now if i'm correct.

    About V435, raced with the Podium Porsche and Formula V2 yesterday and didn't notice any big differences other than the flag leds that aren't lighting up the entire room anymore ;)

    Something i'm "experiencing" last few versions is that sometimes i have a grainy feeling in the steering wheel. Doesn't last more than a few seconds and it isn't something that always happens at the same place / time. Had it yesterday also while driving GT3 cars in iRacing and will see if i can reproduce it somewhere later this week when i have some more time.

  • Everybody who has a DD1/2 has the jolts, do you use the Oled screen or do you leave it on the Fanatec logo after startup? When displaying ITM data or wheelbase telemetry on the screen you should experience those jolts. Devs made a workaround for it, as long as you keep the base on the Fanatec logo you won''t experience any jolts so that's probably the reason why you don't have them ;)

  • Marcel PfisterMarcel Pfister Member, Administrator
    edited January 2022

    McLaren V2 Firmware v43

    To downgrade from current v44 which has an issue with the right clutch paddle input

    1. unpack the .zip
    2. open firmware manager
    3. check "manual update" box in top right
    4. start steering wheel firmware update for McLaren V2
    5. use button with 3 dots to browse the hex file you've unpacked

  • Hello,

    Just wanted to let you know this is not fixed and still happening:

    Podium DD

    • Fixed error message of "exceeded maximum rotation" getting shown without reason

    How to fix this?

  • edited January 2022

    When Fanatec did not fixed it, then you can also not fix it if it is shown without a reason but you then have to wait for the next Firmware release..

  • Marcel PfisterMarcel Pfister Member, Administrator
  • Marcel PfisterMarcel Pfister Member, Administrator

    Do you use Natural Friction ( NFR)? If yes, please give NFR at OFF a try

    In which game do you experience it, in all of them or a specific one?

  • Marcel PfisterMarcel Pfister Member, Administrator

    I'm not aware of this issue.

    Which was the last base firmware where this issue did not happen? Does it work fine when you go back to this version?

    Which was the first version where the issue started happening?

    When the base freezes, nothing works anymore and you need to restart it?

  • Marcel PfisterMarcel Pfister Member, Administrator

    How is your wheel behaving after the message is shown, does it function normally including FFB while the message is shown or does it loose FFB?

  • Im not sure. It showed the message at the end of my game yesterday. Don’t know if it was there for a while.

    At least I could play for an hour or 3 without it, while with the previous driver it was multiple times an hour. With the 43 driver the wheel got stuck and drive in to walls.

    I’m gonna play tonight and keep you updated.

  • Marcel,

    with base firmware 675 the Podium DD works fine in combination with a P1 wheel and yes, it again works fine going back to that version.

    I first realized the issue with base firmware 687 but have to admit, I haven't tried all the versions in between.

    Yes, the base becomes totally unresponsive, not even the rear power button will work to shut it off. Have to pull the power plug.

    I just installed driver 435, base 691 and motor 42 via my notebook to check the current state. Still the same, base at first reacts as usual but becomes unresponsive after some time. Once that has happend it only takes 2 to 3 minutes after rebooting the base to happen again.

    Clicking on the steering wheel tab in the new fanatec ui while the base is still responsive gives the following error message if a P1 wheel is attached:

    Hope that helps



  • edited January 2022

    For me the P1 wheels are working fine on all Firmware versions also after 675... So it's not a general issue I would say. If it would be a widespread general issue I am sure there would be plenty of reports during the last 1.5 years since 675 but there is not one other report, seems you are the only one with that issue..

    But I think you are using Windows 7 judging from that Screenshot..?! That old OS is not supported by Fanatec drivers and Firmwares since 2 years anymore. Maybe this is one reason the UI is Crashing for you as the driver is just no longer compatible with your Windows 7 installation?!

  • Wheel did it again during a league race. Just locking in the position it is in and not reacting to any button or movement of the wheel untill you restart the wheel

  • edited January 2022

    Well, when you wheel is no longer working and even FFB is no longer working then the error message is shown for a reason and therefore correctly.

    Previously this error message of exceeded Maximum Rotations could come up for no reason and everything worked fine, this was fixed with driver 435 and included firmwares so the error message is only shown when it actually should show in case of a real issue.

    So That you get the message shown is at least correct and intended.

  • For a reason? I never had this before updating to 433 And 435. Being enjoying the wheel for 1.5 year now. This just happened after the updates.

    I can only add that for now it only happened in F1 2021.

    At least tell me how the wheel is programmed with the max rotation thing so I can think with you.

    thanks for the help

  • Marcel PfisterMarcel Pfister Member, Administrator

    I have no time frame at the moment, a couple of additional findings were discovered lately after completing part of the re-write and are getting addressed right now.

    I'll ask the dev team about a possible time frame.

This discussion has been closed.