GT7 not recognising CSL Elite pedals LC

Hi, everyone

just having a little headache on my CSL Elite Pedals LC don’t work on Gran Turismo 7. On the the game The CSL Elite wheel base works fine , I can change up and down gears, browse through the menu. Just my pedals is the issue. I checked on PC, all pedals are working. Accelerate, brake and clutch. It might be a simple solution. Just need expert help 👍🏻



  • Sorry guys. I just saw someone had the same issue. I had the USB connected from the pedals to the PS5. I disconnected the USB and the pedals are working.

    hope this helps someone else 👍🏻

  • I have the same problem. CSL elite wheel with club sport pedals V3, everything works fine except the pedals with Gran Turismo seven on PS five. I’ve updated the firmware on all. Anyone have any answers?

  • IM having same issues, tried updating and downgrading firmare, everything works fine on PC, no response from pedals on Ps5 and GT7..

  • Dominic BrennanDominic Brennan Member, Administrator

    Jamie's issue was connecting the pedals via USB to the PS5, which doesn't work. If you are connecting via RJ12 to your wheel base and it still doesn't work, and the issue is unique to GT7, then it is possible that you have a small amount of unwanted input on your brake pedal that is being detected by the game. In a standing start situation, this small amount of brake can prevent you from moving and make it seem like the pedals aren't working, because it triggers some kind of auto clutch. You might see the 'ABS' symbol flickering if this is happening. You can try to manually calibrate your pedals on PC, adding a bit more deadzone on the brake (rest your foot slightly on the brake while clicking the 'Min' button).

    [Fanatec Community Manager]

  • Lo tengo todo bien conectado , lo he revisado varias veces y el pedal de acelerador, no funciona, el servicio Fanatec es lento y sin dar solución, estoy metido en un bucle y no veo salida.

    Si no me dan una pronta y favorable solución, utilizaré todos los medios posibles, para difundir mi problema

  • edited April 2022

    I did this and it had no effect on my pedals. I still can’t break, accelerate or do anything with my V3 pedals on my PS4.

    i have the single rj12 connected into the pedal slot and it doesn’t register

  • Hello! I have the same problem. Couple days ago I played my GT7 the pedals works for about good 30 seconds then stop working afterwards. The car is not moving but I can hear the rpm’s went up when I put clutch and gas at the same time. Is there something wrong with GT7 database or is fanatec problem? Please help!

    but all other racing games it works fine to me except gt7

  • Ahmad AlsalemAhmad Alsalem Member
    edited October 2022

Sign In or Register to comment.